AnsweredAssumed Answered

[SOLVED] /share login failure

Question asked by almoehi on Jan 28, 2010
Latest reply on Feb 2, 2010 by almoehi
Hi,

I've set up a little alfresco server for our project. But I'm experiencing the same problem as many others in this forum:
I cannot login to /share, only to /alfresco
The difference is that I don't see any errors in the log.

My configuration / setup process:
OpenSUSE 11.1
alfresco 3.2r2 community
tomcat that came with alfresco
mysql  Ver 14.12 Distrib 5.0.67, for suse-linux-gnu (i686)
sun jdk 1.6.0_17
ImageMagick 6.4.3.6-5.5.1
OpenOffice  3.0.0.9-1.10
swftools  0.9.0-2.pm.4.1
Flash-player 10.0.42.34-0.2.1

  • installed/verified existence of prerequisites

  • alfresco community bundle unpacked to /usr/share/alfresco_tomcat

  • war files moved to other location; adapted AppBase in server.xml

  • installed SharePoint connector (vti)

  • installed german language pack

  • installed WCM

  • set up mysql (was already installed, did not use the one that came bundled)

  • created directory for alfresco data repo

  • configured alfresco-global.properties

  • made sure that firewall does not block localhost traffic

  • did not change the port or rename the war files

  • there are no permission issues (tomcat runs as root for testing; I'll try to change that later)


  • started tomcat via alfresco.sh (adapted ALF_HOME accordingly)
  • -> tomcat listening on port 8080
  • tried http://localhost:8080/alfresco
  • -> worked; login as guest or admin possible; could play around with it
  • created a new user account
  • -> succeeded
  • tried to upload a file
  • -> success
  • tried http://localhost:8080/share
  • -> login screen came up
  • tried to login using all known users
  • -> got "The remote server may be unavailable or your authentication details have not been recognized" each time
I should mention that Opera 10.10.2742, Firefox 3.0.16 and 3.6 were used for testing.




In the beginning I used an apache proxy and ssl, but when this error occured, I boiled everything down to the default configuration (tomcat only, port 8080, localhost). Obviously without success.



I've read all forum entries related to this issue and tried some of the proposals, but none did the trick.



The only error that my alfresco.log contains is:

ERROR [org.alfresco.fileserver] Failed to get local domain/workgroup name, using default of WORKGROUP
ERROR [org.alfresco.fileserver] (This may be due to firewall settings or incorrect <broadcast> setting)
Does not sound that bad.


The only error that I found in catalina.out was:

log4j:ERROR LogMananger.repositorySelector was null likely due to error in class reloading, using NOPLoggerRepository.
Doesn't seem to be the reason.


I've also tried to enable debug messages as proposed here.
The content of my alfresco.log then was 

19:49:56,042 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/repository.properties]
19:49:56,044 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/domain/transaction.properties]
19:49:56,044 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from URL [file:/usr/share/alfresco_tomcat/tomcat/shared/classes/alfresco-global.properties]
19:49:56,233 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:24,916 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
19:50:25,751 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
19:50:26,238 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'sysAdmin' subsystem, ID: [sysAdmin, default]
19:50:26,268 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:26,282 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'sysAdmin' subsystem, ID: [sysAdmin, default] complete
19:50:29,460 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'thirdparty' subsystem, ID: [thirdparty, default]
19:50:29,478 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:32,223 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'thirdparty' subsystem, ID: [thirdparty, default] complete
19:50:32,369 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /daten/alfresco_data
19:50:32,443 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Sucht nach anwendbaren Patches…
19:50:32,845 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Es sind keine Patches erforderlich
19:50:32,863 INFO  [org.alfresco.repo.module.ModuleServiceImpl] 1 Modul(e) gefunden.
19:50:33,073 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Starte Modul 'org.alfresco.module.vti' Version 1.2.
19:50:33,238 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'fileServers' subsystem, ID: [fileServers, default]
19:50:33,267 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:33,533 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'Authentication' subsystem, ID: [Authentication, managed, alfrescoNtlm1]
19:50:33,556 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:33,722 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Authentication' subsystem, ID: [Authentication, managed, alfrescoNtlm1] complete
19:50:38,735 ERROR [org.alfresco.fileserver] Failed to get local domain/workgroup name, using default of WORKGROUP
19:50:38,735 ERROR [org.alfresco.fileserver] (This may be due to firewall settings or incorrect <broadcast> setting)
19:50:38,823 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'fileServers' subsystem, ID: [fileServers, default] complete
19:50:38,824 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'imap' subsystem, ID: [imap, default]
19:50:38,888 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:39,054 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'imap' subsystem, ID: [imap, default] complete
19:50:39,064 INFO  [org.alfresco.repo.usage.UserUsageTrackingComponent] Enabled - calculate missing user usages …
19:50:39,099 INFO  [org.alfresco.repo.usage.UserUsageTrackingComponent] Found 0 users to recalculate
19:50:39,107 INFO  [org.alfresco.repo.usage.UserUsageTrackingComponent] … calculated missing usages for 0 users
19:50:39,107 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'Synchronization' subsystem, ID: [Synchronization, default]
19:50:39,130 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:50:39,215 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Synchronization' subsystem, ID: [Synchronization, default] complete
19:50:39,567 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_17-b04; maximum heap size 506,313MB
19:50:39,568 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community): Current version 3.2.0 (r2 2440) schema 3300 - Originally installed version 3.2.0 (r2 2440) schema 3300
19:51:03,521 INFO  [org.alfresco.module.vti.VtiServer] Vti server started successfully on port: 7070
19:51:23,996 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'wcm_deployment_receiver' subsystem, ID: [wcm_deployment_receiver, default]
19:51:24,093 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
19:51:24,302 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'wcm_deployment_receiver' subsystem, ID: [wcm_deployment_receiver, default] complete
19:51:28,712 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/chrome'.
19:51:28,717 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/components'.
19:51:28,718 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/component-types'.
19:51:28,719 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/configurations'.
19:51:28,721 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/content-associations'.
19:51:28,722 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/pages'.
19:51:28,723 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/page-associations'.
19:51:28,746 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/page-types'.
19:51:28,752 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/template-instances'.
19:51:28,753 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/template-types'.
19:51:28,754 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/themes'.
19:51:28,774 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/presets'.
19:51:28,829 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-webscripts'.
19:51:28,829 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/templates'.
19:51:29,072 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/chrome'.
19:51:29,073 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/components'.
19:51:29,073 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/component-types'.
19:51:29,074 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/configurations'.
19:51:29,075 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/content-associations'.
19:51:29,076 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/pages'.
19:51:29,076 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/page-associations'.
19:51:29,077 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/page-types'.
19:51:29,078 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/template-instances'.
19:51:29,078 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/template-types'.
19:51:29,079 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/themes'.
19:51:29,538 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore initialised with endpoint id 'alfresco' API path '/remotestore' path prefix 'alfresco/site-data/presets'.
19:51:29,554 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
19:51:29,982 INFO  [org.alfresco.config.JBossEnabledWebApplicationContext] Refreshing org.alfresco.config.JBossEnabledWebApplicationContext@1abdc38: display name [Root WebApplicationContext]; startup date [Thu Jan 28 19:51:29 CET 2010]; root of context hierarchy
19:51:30,247 INFO  [org.alfresco.config.JBossEnabledWebApplicationContext] Bean factory for application context [org.alfresco.config.JBossEnabledWebApplicationContext@1abdc38]: org.springframework.beans.factory.support.DefaultListableBeanFactory@a2918c
19:51:31,670 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 22 Web Scripts (+0 failed), 24 URLs
19:51:31,681 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 204.62383ms)
19:51:31,764 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 40 Web Scripts (+0 failed), 42 URLs
19:51:31,776 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 93.09494ms)
19:51:31,821 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
19:52:15,632 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/pages/site-index.xml?s=sitestore
19:52:15,633 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,713 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,713 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,714 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() site-index.xml = false
19:52:15,720 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/configurations/slingshot.site.configuration.xml?s=sitestore
19:52:15,721 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,760 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,760 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,760 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() slingshot.site.configuration.xml = false
19:52:15,767 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/themes/default.xml?s=sitestore
19:52:15,767 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,772 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,772 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,772 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() default.xml = false
19:52:15,775 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/pages/slingshot-login.xml?s=sitestore
19:52:15,775 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,780 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,780 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,780 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() slingshot-login.xml = false
19:52:15,782 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/template-instances/slingshot-login.xml?s=sitestore
19:52:15,782 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,787 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,788 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,788 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() slingshot-login.xml = false
19:52:15,798 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/template-types/org/alfresco/global/slingshot-login.xml?s=sitestore
19:52:15,798 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,809 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,809 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,809 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() org/alfresco/global/slingshot-login.xml = false
19:52:15,809 DEBUG [org.alfresco.connector.RemoteClient] Executing (GET) http://localhost:8080/alfresco/wcs/remotestore/has/alfresco/site-data/template-types/freemarker.xml?s=sitestore
19:52:15,809 DEBUG [org.alfresco.connector.RemoteClient]  - OutputStream supplied - will stream response…
19:52:15,819 DEBUG [org.alfresco.connector.RemoteClient] Response status code: 200
19:52:15,819 DEBUG [org.alfresco.connector.RemoteClient] Response encoding: null
19:52:15,819 DEBUG [org.alfresco.web.scripts.RemoteStore] RemoteStore.hasDocument() freemarker.xml = false
All these GET requests seem to succeed.




Does anybody have an idea what else I could try?



Thanks,
Alex

Outcomes