AnsweredAssumed Answered

Inbound email configuration/ email enabled spaces

Question asked by shikarishambu on Sep 25, 2009
Latest reply on Oct 5, 2009 by shikarishambu
Hi,
I am having issues getting inbound email/ email enabled spaces to work. I am trying to setup my spaces to accept email.

I have done the following

1. Created the space(s)
2. Gone to View Details > Run Action > Add Aspect > Email Alias on the space(s).
3. Set the configuration in tomcat\shared\classes\alresco\extension\custom-email-server.properties to

# Enable/Disable the inbound email service.  The service could be used by processes other than
# the Email Server (e.g. direct RMI access) so this flag is independent of the Email Service.
email.inbound.enabled=true
# The username to authenticate as when the sender address is not recognised
email.inbound.unknownUser=anonymous

# Email Server properties
email.server.enabled=true
email.server.port=25
email.server.domain=<<mycompany>>.com


#
# A comma separated list of email REGEX patterns of allowed senders.
# If there are any values in the list then all sender email addresses
# must match.  For example:
#   .*\@alfresco\.com, .*\@alfresco\.org
# Allow anyone:
email.server.allowed.senders=.*

#
# A comma separated list of email REGEX patterns of blocked senders.
# If the sender email address matches this then the message will be rejected.
# For example:
#   .*\@hotmail\.com, .*\@googlemail\.com
#email.server.blocked.senders=

I continue to get the following errors
The email address 'input@s<<mycompany>>.com' does not reference a valid accessible node. ##

I am not sure if I missed some other setting. Also is there a way to see / edit the aspect applied to a pace using Run Actions

Outcomes