AnsweredAssumed Answered

CIFS and Kerberos authentication errors

Question asked by cmgray on Jan 29, 2010
Latest reply on Feb 3, 2010 by cmgray
I've searched for answers to this problem and have yet to see anyone that is experiencing what I am right now.

I have community 3.2r2 setup to use kerberos authentication for CIFS. 

I have the configuration all set from what I can tell, after some back and forth we finally got the CIFS principal and keytabs set correctly so that I get this in the log when I start alfresco.


14:43:36,906 DEBUG [org.alfresco.smb.protocol.auth] Logged on using principal CIFS/dev-alfresco.my.host@MY.REALM
14:43:36,906 DEBUG [org.alfresco.smb.protocol.auth] Enabling mechTypes :-
14:43:36,906 DEBUG [org.alfresco.smb.protocol.auth]   Kerberos5
14:43:36,906 DEBUG [org.alfresco.smb.protocol.auth]   MS-Kerberos5

14:43:36,911 INFO  [org.alfresco.fileserver] CIFS server started


So that tells me that CIFS is started and that the kerberos authentication is ready to go.

Well when I try to authenticate I get only this in the log:

14:46:54,009 DEBUG [org.alfresco.smb.protocol.auth] Using Write transaction


I tried to trace the problem down and added some additional debugging statements into the EnterpriseCifsAuthenticator.java class and finally got it down to this error. 
Attempt to use non SSO-enabled authentication component for SSO

This is thrown on line 458 of CifsAuthenticatorBase.java

I'm at a loss as to what to try next.  Does anyone have any ideas?

Thanks,

Chris

Outcomes