AnsweredAssumed Answered

Strange CIFS/NTLM Authentication Issue (Windows 7 and 2008)

Question asked by maximus007 on Feb 4, 2010
Latest reply on Feb 4, 2010 by maximus007
I'm getting close to getting this server set up!

I am having a strange issue authenticating CIFS for users on Windows 7 and Server 2008 machines. Alfresco is set up to use NTLM authentication.

For some reason, only the original "admin" user can actually access the \\alfresco\alfresco share. When using the admin user, I get the expected output in the log:

11:33:30,748 User:admin DEBUG [smb.protocol.auth] Logged on using NTLMSSP/NTLMv2
11:33:30,749 User:admin DEBUG [smb.protocol.auth] Using Write transaction
But, if I try log in with any other user on the very same machine, I get the following message:

11:24:06,439  DEBUG [smb.protocol.auth] NT Session setup NTLMSSP, MID=8, UID=0, PID=65279
11:24:06,439  DEBUG [smb.protocol.auth] Using Write transaction
11:24:06,439  DEBUG [smb.protocol.auth] Kerberos AP-REQ - [AP-REQ:APOptions=MutualAuth ,Ticket=Len=1223,Authenticator=EncType=23,Kvno=-1,Len=234]
11:24:06,439  DEBUG [smb.protocol.auth] Kerberos mutual auth required, parsing AP-REQ
11:24:06,439  ERROR [smb.protocol.auth] Kerberos logon error
11:24:06,439  ERROR [smb.protocol.auth] java.lang.NullPointerException
I have tried this on numerous Windows 7 or 2008 machines - all allow admin to connect but no one else. WebDAV, FTP and Alfresco Explorer all work fine.

I then tried it on an XP Virtual Machine and a Server 2003 machina and what do you know - all users can authenticate as expected!?

What on earth is going on?

Outcomes