AnsweredAssumed Answered

Error starting Alfresco after AMP installation

Question asked by andrea81it on Feb 4, 2010
Latest reply on Feb 5, 2010 by andrea81it
Hi,
i found and installed an AMP extension which provide hyperlinks for associations:

http://wiki.alfresco.com/wiki/AMP_for_Web_Client_Links_in_Associations

installed following instructions here:

http://wiki.alfresco.com/wiki/Module_Management_Tool

…and configured the AMP as described, with a faces-config-custom.xml file in my Eclipse project, deployed using the usual ANT script.
Starting Alfresco, i have a "bad stack trace":

09:45:34,531  ERROR [web.context.ContextLoader] Context initialization failed
org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Failed to import bean definitions from URL
location [classpath:alfresco/application-context.xml]
Offending resource: ServletContext resource [/WEB-INF/web-application-context.xml]; nested exception is org.springframework.beans.factory.Be
anDefinitionStoreException: IOException parsing XML document from class path resource [alfresco/application-context.xml]; nested exception i
s java.io.FileNotFoundException: class path resource [alfresco/application-context.xml] cannot be opened because it does not exist
Caused by: org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from class path resource [alfres
co/application-context.xml]; nested exception is java.io.FileNotFoundException: class path resource [alfresco/application-context.xml] canno
t be opened because it does not exist
Caused by: java.io.FileNotFoundException: class path resource [alfresco/application-context.xml] cannot be opened because it does not exist
        at org.springframework.core.io.ClassPathResource.getInputStream(ClassPathResource.java:135)
        at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:307)
        at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:290)
        at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:131)

        at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:147)

        at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.importBeanDefinitionResource(DefaultBeanDefinitionDocum
entReader.java:171)

What's wrong?
Before the installation, it worked all fine…
Maybe the faces-config.custom.xml is in a wrong place? I tried to put in in webapps/alfresco/WEB-INF and in webapps/alfresco/WEB-INF/classes/alfresco/extension, but i can't solve this problem and the worst thing is that i can't remove the AMP extension.
Thank you very much in advance!

Outcomes