AnsweredAssumed Answered

Alfresco 4 + MS Office 2010 Sharepoint issue.

Question asked by jalxm on Feb 5, 2012
Latest reply on Oct 23, 2013 by johseb
Hello all,

I have installed MS Office 2010 on my laptop with WIndows 7 Ultimate 64bit (SP1)
Then I read instructions in http://docs.alfresco.com/4.0/topic/com.alfresco.enterprise.doc/concepts/SharePoint-onlineedit.html

1. Installed patch KB907306 http://www.microsoft.com/downloads/details.aspx?familyid=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
2. Added keys in regedit with value 2 for both
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel" (REG_DWORD)
“HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet\BasicAuthLevel” (REG_DWORD)

3. Restarted windows.
4. Added properties in alfresco-global.properties

### Sharepoint ###
vti.server.port=7070
vti.alfresco.deployment.context=/alfresco
vti.alfresco.alfresoHostWithPort=http://127.0.0.1:8080
vti.share.shareHostWithPort=http://127.0.0.1:8080
vti.share.shareContext=/share

5. Start alfresco.
6. Open Start->Sharepoint->Microsoft SharePoint Workspace 2010
And click on Create-> Sharepoint Workspace
7. Added path http://localhost:7070/alfresco and click Ok button
8. I have got login form to enter login/password
I put my credentials for admin and received error message about Sharepoint Workspace synchronization error.

9. In tomcat logs I saw exceptions

2012-02-05 12:32:39,852  WARN  [web.actions.VtiSoapAction] [346428597@qtp-802590979-0] Failure executing Vti request
java.lang.NullPointerException
   at org.alfresco.module.vti.web.ws.GetWebEndpoint.execute(GetWebEndpoint.java:78)
   at org.alfresco.module.vti.web.actions.VtiSoapAction.execute(VtiSoapAction.java:77)
   at org.alfresco.module.vti.web.VtiRequestDispatcher.doActions(VtiRequestDispatcher.java:238)
   at org.alfresco.module.vti.web.VtiRequestDispatcher.service(VtiRequestDispatcher.java:147)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
   at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1221)
   at org.alfresco.module.vti.web.VtiFilter.doFilter(VtiFilter.java:190)
   at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
   at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:399)
   at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
   at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
   at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
   at org.mortbay.jetty.Server.handle(Server.java:326)
   at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
   at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:945)
   at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756)
   at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218)
   at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
   at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)
   at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
2012-02-05 12:32:39,905  WARN  [web.actions.VtiSoapAction] [346428597@qtp-802590979-0] Failure executing Vti request
java.lang.NullPointerException
   at org.alfresco.module.vti.web.ws.WebUrlFromPageUrlEndpoint.execute(WebUrlFromPageUrlEndpoint.java:76)
   at org.alfresco.module.vti.web.actions.VtiSoapAction.execute(VtiSoapAction.java:77)
   at org.alfresco.module.vti.web.VtiRequestDispatcher.doActions(VtiRequestDispatcher.java:238)
   at org.alfresco.module.vti.web.VtiRequestDispatcher.service(VtiRequestDispatcher.java:147)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
   at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
   at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1221)
   at org.alfresco.module.vti.web.VtiFilter.doFilter(VtiFilter.java:190)
   at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
   at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:399)
   at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
   at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
   at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
   at org.mortbay.jetty.Server.handle(Server.java:326)
   at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
   at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:945)
   at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756)
   at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218)
   at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
   at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)
   at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)

Last community Alfresco 4.0.c installed.

Could you help me with the following issue?…

Outcomes