AnsweredAssumed Answered

OpenOffice/Preview No Worky

Question asked by n0hr on Oct 5, 2009
Latest reply on Oct 7, 2009 by rliu
Guys,

I'm really hoping you can help…  Alfresco is running but won't talk to OpenOffice.

My system once had all the pieces working fine. Then I decided to test backup/restore… so I backed up everything and removed Alfresco. Then I did a fresh install:
- Alfresco 3.2 CE
- Separate MySQL install

My Alfresco install included OpenOffice. However, once I got Alfresco running again, the OpenOffice preview function wasn't working. Checking the log, I found the dreaded:

15:34:12,932 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
15:34:17,739 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
15:34:17,741 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'thirdparty' subsystem, ID: [default] complete
15:34:18,208 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\Alfresco\alf_data


Arrg! 

Ok, I've tried a lot of things without luck to get this running. Including updating my global-properties file:


# Sample custom content and index data location
#————-
dir.root=C:/Alfresco/alf_data

#
# Sample database connection properties
#————-
db.name=alfresco
db.username=alfresco
db.password=alfresco
db.host=localhost
db.port=3306

#
# External locations
#————-
#ooo.exe=C:/Alfresco/OpenOffice.org/program/soffice
#ooo.exe=C:\\Alfresco\\OpenOffice.org\\program\\soffice.exe
ooo.exe=C:\\Program Files (x86)\\OpenOffice.org 3\\program\\soffice.exe
#ooo.exe=C:/Program Files (x86)/OpenOffice.org 3/program/soffice.exe
ooo.user=${dir.root}/oouser
img.root=C:/Alfresco/ImageMagick
swf.exe=C:/Alfresco/bin/pdf2swf

As you can see, I've also tried installing OO separately and then pointing to it - no luck.

I've checked firewall settings:
I have a tcp port open to 50500 (Openoffice)
I have a tcp port open to 8100 (Openoffice)
I have a program exception for C:/Program Files (x86)/OpenOffice.org 3/program/soffice.exe

Any ideas????

Outcomes