AnsweredAssumed Answered

Alfresco Share crashes

Question asked by xzibit12 on Feb 8, 2012
Latest reply on Feb 8, 2012 by xzibit12
I'm using Alfresco 4.0B. It was working fine this morning suddenly my browser hangs so I thought it was my machine but when I checked the server to restart the alfresco service by typing sh alfresco.sh restart, it didn't work and I noticed that all scripts (.sh file) are read-only. So what I did is to chmod 777 the alfresco.sh script then tomcat scripts ctl.sh we're not also working until I set the whole alfresco directory to chmod 777 * -R command, tomcat is now working but postgres was not. I tried to access the localhost:8080/share and it's now working, I can see the login page but when I tried to log the account, authentication problem. I'm sure that the problem was the postgres because it is not running, permission denied error is presented on /opt/alfresco/postgres/bin/postgres. So even all the files are 777 permission, I still received permission denied on postgres file. What could be the problem on why I received postgres permission denied? How can I get back postgres running? Is setting 777 on all files in Alfresco directory have effect? If I reinstall alfresco, will it delete the database?

Outcomes