AnsweredAssumed Answered

HTTP Status 404 - /alfresco/faces/jsp/login.jsp

Question asked by gk17 on Oct 7, 2009
Latest reply on Oct 8, 2009 by gk17
Hi everyone, just joined the forum here. We have Alfresco running here under RedHat Linux Enterprise Edition. Not sure if this will be needed as well, but it's running in a virtual machine (ESX server).

It has been working fine until recently when there was a network problem. The network issue seems to be resolved now and we can get full access to the server. The administrator who installed this on the ESX server is no longer working with us. I usually just go to the alfresco directory and start up the service from there using ./alfresco.sh start. We then wait about 10 minutes and the Alfresco web page works (http://ip_address:8080/alfresco/faces/jsp/login.jsp). Now we get the following error in Internet Explorer:

HTTP Status 404 - /alfresco/faces/jsp/login.jsp

——————————————————————————–

type Status report

message /alfresco/faces/jsp/login.jsp

description The requested resource (/alfresco/faces/jsp/login.jsp) is not available.


——————————————————————————–

Apache Tomcat/5.5.23

One thing I did notice is that there is no faces directory. Not sure if that can be the cause of this problem (seems to be logically). If so, how can we fix this?

I also noticed that the "web server service" wasn't running either. So I went into the init.d directory and started httpd service. I also increased the size of the file handling block (suggested by the Alfresco administrator before he left) by running ulimit -n 4096.

I am not a big Linux user but do know the basic commands and have no problems working in the command prompt which I have been doing for the most part.

I have tried to search online for a solution but couldn't find one. Some mentioned not connecting to the database but from the error shown, it doesn't seem to be related.

Please advise and let us know how to proceed from here.

Thanks.

Outcomes