AnsweredAssumed Answered

How verify that the Sharepoint Protocol correct installed?

Question asked by agb80 on Feb 15, 2012
I'm using Alfresco 4.0c installed on a Centos 5 VPS. I'm trying to configure Sharepoint Protocol module, look around on forums, wikis and other places but coudn't make it work yet. Could you please send me a hand?

I have download the Sharepoint Module from this link: https://process.alfresco.com/ccdl/?file=release/community/build-4003/alfresco-community-spp-4.0.d.zip

Unziped and installed the .amp using this instruction:

java -jar alfresco-mmt.jar install "/opt/alfresco40c/amp/alfresco-community-spp-4.0.d.amp" "/opt/alfresco40c/tomcat/webapps/alfresco.war" -verbose"/opt/alfresco40c/tomcat/webapps/alfresco.war" -verbose     

Using this other instruction I can see the module listed on the alfresco.war

 java -jar alfresco-mmt.jar list "/opt/alfresco40c/tomcat/alfresco.war"

I have atached this code to my alfresco-global.properties:


#Alfresco SharepointProtocol configuration
vti.server.port=7070
vti.alfresco.deployment.context=/alfresco
vti.alfresco.alfresoHostWithPort=http://servername.net:8080
vti.share.deployment.context=/share
vti.share.shareHostWithPort=http://servername.net:8080
vti.server.external.host=http://servername.net
vti.server.external.port=7070

Is that all the configuration needed to make Sharepoint Protocol work? How can I test that the module is properly configured and running for discart that my hosting server firewall is not blocking the comunications on 7070 port?

Outcomes