AnsweredAssumed Answered

Cifs Editing in Alfresco 3.2 destroys working copy

Question asked by sebp on Oct 13, 2009
Latest reply on Oct 14, 2009 by sebp
I switched to Alfresco 3.2 and run into some problems with cifs editing. After editing a working copy of a document with an external editor via cifs and saving that document a new node is created. This new node is a new document and is not linked to the original document and therefore can not be checked in.

I set up my alfresco:

1. I put the alfresco.war into the webapps dir of my tomcat, put the alfresco-global.properties in /shared/classes and let it point to an empty database and empty content store.
2. I added the file-servers-custom.xml from the samples into the /shared\classes\alfresco\extension without changing anything.
3. Started tomcat so that the war is deployed
4. Stopped tomcat, in the deployed directory I changed the default-edit-link to cifs in web-client-config.xml and also enabled the "Old actions previously used for online/offline editing" in web-client-config-actions.xml
5. Restarted tomcat.

I think these are the basic steps to enable cifs editing. Now here comes my problem, if I:

1. Upload a file named  MyDoc.tex file
2. Click on 'Edit Online'.
3. My Latex editor opens, I change the document and save it.
4. I go back to Alfresco and click 'Done Editing'.
5. An error message is shown in the client:

javax.faces.el.EvaluationException: Exception while invoking expression #{DoneEditingDialog.handle}
caused by:
org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/ccba3c9c-7a48-4422-a770-16ca87cec45e
If I click on the details among other things there is:

Caused by: org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/ccba3c9c-7a48-4422-a770-16ca87cec45e
at org.alfresco.repo.node.db.DbNodeServiceImpl.getNodePairNotNull(DbNodeServiceImpl.java:158)
at org.alfresco.repo.node.db.DbNodeServiceImpl.hasAspect(DbNodeServiceImpl.java:719)

If I go back to the folder where the document and the working copy are I can see that the document is there but not checked out at all and the working copy is there named MyDoc (Working copy).tex but there is no 'Done Editing' button. Instead both, the document and the working copy, have the normal document action buttons. They are two separat documents not linked to each other in any way.
I realised that every time when I save a working copy a new node is created (the node id of the working copy changes). This new node has the " (Working Copy)" prefix but is not linked to the original document.

If this would be a bug then someone should have seen this before. But I couldn't find anything in jira. So I hope it's only a configuration issue or something. I would be glad if anyone could help me with this.

Outcomes