AnsweredAssumed Answered

Java/OpenOffice problem with 3.3 on Ubuntu 10.10

Question asked by ryank on Feb 22, 2012
Latest reply on Feb 26, 2012 by ryank
I have my new VPS set up with Ubuntu 10.10 64-bit and I'm following this howto:

http://www.howtoforge.com/how-to-install-alfresco-community-3.3-on-ubuntu-server-10.04-lucid-lynx

All good until I get to the part where I start the openoffice service:

root@dms:~# /usr/lib/openoffice/program/soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard &

I get the error:

javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package openoffice.org-java-common is installed.
If it is already installed then try removing ~/.openoffice.org/3/user/config/javasettings_Linux_*.xml

[1]+ Done               /usr/lib/openoffice/program/soffice "-accept=socket,host=localhost,port=8100; urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard

So it looks like a java problem, and I run

java -version

which gets

Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java Virtual Machine

I am running a new VPS with these specs:
Disk space: 30GB
Memory: 1GB
Burst: 1GB

Memory usage is running at 66% which is odd because when I run top, it says that java is running and is using 54.3% of the cpu.

I'm at a loss as to what to do next. Any help appreciated.

Outcomes