AnsweredAssumed Answered

Alfresco SDK 3.2r2

Question asked by rtoepfer on Feb 17, 2010
I'm a C++ developer by trade who is learning Java/Spring.  I downloaded Eclipse and Alfresco SDK 3.2r2. I've imported the sample projects as outlined in http://wiki.alfresco.com/wiki/Alfresco_SDK_3.2.

The wiki states "Set Eclipse Compiler Compliance Level to 6.0" which I have done.  However, when attempting to build the sample projects I receive errors "Syntax error, annotations are only available if source level is 1.5", "Syntax error, for each statements are only available if source level is 1.5", "Syntax error, paramaterized types are only available if source level is 1.5", etc.  Eclipse suggests changing the compiler level to 1.5 to fix.

Is there something wrong with my setup?  Should I go ahead and tag the wiki with a note saying "keep at 1.5"?  Updating all the example projects to JDK 1.6 is out of my experience level at the moment.

Outcomes