AnsweredAssumed Answered

Not able to access cmis web services

Question asked by bhagavath on Oct 19, 2009
Latest reply on Mar 14, 2010 by openpj
Hi,

i am tryin to use cmisws.wsdl web service which is provided by alfresco.. but when i'm trying to execute any of the method it is asking for authentication..though im sending it in header..Example for getRepositoryInfo..

Requset Soap:

<?xml version="1.0" encoding="UTF-8" ?>
<soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<ns3:Header xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ns1="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:ns2="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:ns3="http://schemas.xmlsoap.org/soap/envelope/"> <ns2:Security mustUnderstand="1"> <ns1:Timestamp> <ns1:Created>2009-10-16T16:04:22.609Z</ns1:Created> <ns1:Expires>2010-10-12T16:04:22.609Z</ns1:Expires> </ns1:Timestamp> <ns2:UsernameToken> <ns2:Username>bhagavathm@virtusa.com</ns2:Username> <ns2:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">TICKET_e9bdc30a131946034d0a326ab36de5292c148622</ns2:Password> </ns2:UsernameToken> </ns2:Security> </ns3:Header>

<soapenv:Body>
<ns1:getRepositoryInfo xmlns:ns1="http://docs.oasis-open.org/ns/cmis/messaging/200901">

</ns1:getRepositoryInfo>
</soapenv:Body>
</soapenv:Envelope>
Response Soap:

<?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<wsse:Security xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
<wsu:Timestamp xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" wsu:Id="Timestamp-18591560">
<wsu:Created>2009-10-16T12:45:20.946Z</wsu:Created>
<wsu:Expires>2009-10-16T12:50:20.946Z</wsu:Expires>
</wsu:Timestamp></wsse:Security>
</soap:Header>
<soap:Body><soap:Fault>
<faultcode>soap:Server</faultcode>
<faultstring>Invalid user name or password specified</faultstring>
</soap:Fault></soap:Body>
</soap:Envelope>

do i need any other authentication for cmis web services.. because using the same soap security header im able to access content service methods..

can any one help me out…thanks in advance..

Bhagavath.

Outcomes