AnsweredAssumed Answered

checkin broken ?

Question asked by hwold on Feb 17, 2010
Latest reply on Jan 14, 2011 by negus
Hello,

I’m using Alfresco as a backend in an application. I need versioning, so I use the web scripts API to perform checkin/checkouts. It works fine with Alfresco 3.2 ; not with Alfresco 3.2r2. I’ve been able to fix my checkout code, but I can’t get checkin working.

Under 3.2, I was just performing a HTTP GET query to:
http://localhost:8080/alfresco/service/api/pwc/workspace/SpacesStore/(node-id)?checkinComment=hello&major=true&alf_method=PUT&checkin=true&alf_ticket=(ticket)

Now, I tried with :
http://localhost:8080/alfresco/service/cmis/pwc/i/(node-id)?checkinComment=hello&major=true&alf_method=PUT&checkin=true&alf_ticket=(ticket)
(BTW, is workspace/SpacesStore no longer needed ? — I also tried with http://localhost:8080/alfresco/service/cmis/pwc/s/workspace/SpacesStore/i/(node-id)?checkinComment=hello&major=true&alf_method=PUT&checkin=true&alf_ticket=(ticket), but that didn’t help)

But I get this error (HTTP 500):
01170011 Wrapped Exception (with status template): 01170010 Error during processing of the template 'Expression checkin is undefined on line 10, column 6 in org/alfresco/cmis/pwc.put.atomentry.ftl.'. Please contact your system administrator.

I tried to replace checkin to args.checkin?? in pwc.put.atomentry.ftl, but then I have this error:
01170013 Wrapped Exception (with status template): 01170012 Error during processing of the template 'Error executing macro: document required parameter: node is not specified.'. Please contact your system administrator.

Should I report the problem on your BT, or did I misuse the CMIS API ?

Outcomes