AnsweredAssumed Answered

Problem with outbound email settings

Question asked by igalvit on Feb 29, 2012
Latest reply on Mar 31, 2012 by vessvass
Hi,

I got some troubles with the configuration of the email settings for outbound email. I'm sure that my email settings are correct and the account is valid. In the alfresco-global.properties I have this setup:

mail.host=smtp.domain.com
mail.port=25
mail.username=invitationuser
mail.password=<password>
mail.encoding=UTF-8
mail.smtp.from=someone@domain.com
mail.from.default=someone@domain.com
mail.smtp.auth=true

But when I send an invitation for a new user I get this error in my alfresco.log file: (The oneadmin@gmail.com address is the email of the System Admin and the user@gmail.com is the address of the new user)

22:45:08,773 ERROR [org.alfresco.web.bean.TemplateMailHelperBean] Failed to send email to user@gmail.com
org.springframework.mail.MailSendException: Failed messages: javax.mail.SendFailedException: Invalid Addresses;
  nested exception is:
        com.sun.mail.smtp.SMTPAddressFailedException: 553 5.7.1 <oneadmin@gmail.com>: Sender address rejected: not owned by user invitationuser
; message exception details (1) are:
Failed message 1:
javax.mail.SendFailedException: Invalid Addresses;
  nested exception is:
        com.sun.mail.smtp.SMTPAddressFailedException: 553 5.7.1 <oneadmin@gmail.com>: Sender address rejected: not owned by user invitationuser

[…]

If I change the System Admin address to someone@domain.com it works perfectly but I don't know how is this possible. Is necessary that the notification user's address is the same as the system administrator's address?

Best regards,

Ignacio

Outcomes