AnsweredAssumed Answered

Community Edition 3.2 starting in Read Only mode

Question asked by natguyton on Oct 23, 2009
Latest reply on Dec 16, 2009 by muthukimoses
I've read a few other posts here and found that Enterprise edition can have licensing issues causing this, and that Community Edition can have issues if <TOMCATHOME>/shared/classes/alfresco/extension/wcm-bootstrap-context.xml has an odd fixesToSchema value, but mine match the appropriate files.  

For some reason, when I try to upload a file in share or WCM I still get a read only error:

14:48:09,529 ERROR [org.alfresco.web.scripts.AbstractRuntime] Exception from executeScript - redirecting to status template error: 09230007 Wrapped Exception (with status template): 09230006 Failed to execute script '/org/alfresco/slingshot/calendar/eventList.get.js (in classpath store file:/usr/local/opt/Alfresco/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/templates/webscripts)': 09230005 Access Denied.  The system is currently in read-only mode.

I am running alfresco as root. 
Other items:
Centos 5.3 64 bit Linux
JVM 1.6.0-14 64 bit  (Sun java download)
Fresh install of 3.2 community edition, no older version
MySQL 5.0.45 64 bit

I am able to create users, create folders in share, just not upload files nor avatar pics.   This tells me that mysql is working fine, but there's something wrong with config writing to the content store or other?

I have it working fine on two other servers, but not this particular one.  Very odd.   Thoughts?

Outcomes