AnsweredAssumed Answered

Alfresco 3.2 community and Jboss 4.2.3 GA

Question asked by konsultex on Oct 26, 2009
Latest reply on Dec 30, 2009 by konsultex
I have an Alfresco 2.1 installation (community) with no customizations working fine in JBoss 4.0.5GA with JDK 1.5.0_x on FC4 but I need to upgrade Alfresco 2.1 to 3.2. Alfresco is one of 4 applications in this JBoss. Here's what I did, following the instructions in the wiki (http://wiki.alfresco.com/wiki/Deploying_Alfresco_on_JBoss):

a) Stopped Jboss
b) backed up alf_data and the Mysql alfresco database
c) upgarded JDK to 1.6.0_16 (I felt that a newer Java would be e good idea)
d) upgraded to JBoss 4.2.3GA
e) Copied the old conf/alfresco to the new JBoss and copied the new war to /deploy
f) When I first restarted I got the error about the avm_issuer_ids table and I solved it: http://forums.alfresco.com/en/viewtopic.php?f=8&t=20266&p=66496&hilit=create+table+avm_issuer_ids#p66496
g) I started again with a fresh restore of my SQL and alf_data backups (database with avm_issuer_ids) .
hI still get an error but I have no clue about the origin of the problem.


….
2009-10-25 22:22:23,938 INFO  [STDOUT] 22:22:23,938 User:System INFO  [admin.patch.PatchExecuter]       Applying patch 'patch.wcmPostPermissionSnapshotPatch3' (Snapshot stores (after fixing ACLs so they are only set on the staging area store).).                                          
2009-10-25 22:22:23,943 INFO  [STDOUT] 22:22:23,943 User:System ERROR [admin.patch.PatchExecuter] 09250001 com.ibatis.sqlmap.client.SqlMapException: There is no statement named select.AVMNodeEntitiesCountWhereNewInStore in this SqlMap.                                                    
        at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.getMappedStatement(SqlMapExecutorDelegate.java:231)                            
        at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.queryForObject(SqlMapExecutorDelegate.java:509)                                
        at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.queryForObject(SqlMapExecutorDelegate.java:493)                                
        at com.ibatis.sqlmap.engine.impl.SqlMapSessionImpl.queryForObject(SqlMapSessionImpl.java:106)                                          
        at org.springframework.orm.ibatis.SqlMapClientTemplate$1.doInSqlMapClient(SqlMapClientTemplate.java:244)                               
        at org.springframework.orm.ibatis.SqlMapClientTemplate.execute(SqlMapClientTemplate.java:194)                                          
        at org.springframework.orm.ibatis.SqlMapClientTemplate.queryForObject(SqlMapClientTemplate.java:242)                                   
        at org.springframework.orm.ibatis.SqlMapClientTemplate.queryForObject(SqlMapClientTemplate.java:236)                                   
        at org.alfresco.repo.domain.patch.ibatis.PatchDAOImpl.getAVMNodeEntitiesCountWhereNewInStore(PatchDAOImpl.java:56)                     
        at org.alfresco.repo.domain.patch.AbstractPatchDAOImpl.getAVMNodesCountWhereNewInStore(AbstractPatchDAOImpl.java:44)                   
        at org.alfresco.repo.domain.hibernate.AclDaoComponentImpl.getNewInStore(AclDaoComponentImpl.java:2054)                                 
        at org.alfresco.repo.admin.patch.impl.WCMPostPermissionSnapshotPatch.applyInternal(WCMPostPermissionSnapshotPatch.java:75)  
…..          

This happens about 40% into the completion of the "Patch".

Am I missing something else?

Thanks.

Outcomes