AnsweredAssumed Answered

UTF-8 characters in LDAP names?

Question asked by jbravo on Mar 2, 2012
Hello all.

I'm trying to get Alfreaco 4.0.d to work with AD.   I've followed all documentation and I'm stuck at a strange problem.    People can log in using AD credentials and I can search for, and find, groups but there is no info about any of the users (or groups).    I see in the logs that it's having problems syncing AD:

2012-03-02 17:23:16,325  WARN  [sync.ldap.LDAPUserRegistry] [main] Failed to resolve member of group 'Nemendur' with distinguished name: CN=2210932919,OU=Nemendur,OU=Notendur,OU=Vi?f?ng,DC=net,DC=mydomain,DC=is
2012-03-02 17:23:16,325  WARN  [sync.ldap.LDAPUserRegistry] [main] Failed to resolve member of group 'Nemendur' with distinguished name: CN=2009903319,OU=Nemendur,OU=Notendur,OU=Vi?f?ng,DC=net,DC=mydomain,DC=is
2012-03-02 17:23:16,325  WARN  [sync.ldap.LDAPUserRegistry] [main] Failed to resolve member of group 'Nemendur' with distinguished name: CN=2502902689,OU=Nemendur,OU=Notendur,OU=Vi?f?ng,DC=net,DC=mydomain,DC=is
2012-03-02 17:23:16,325  WARN  [sync.ldap.LDAPUserRegistry] [main] Failed to resolve member of group 'Nemendur' with distinguished name: CN=1512924029,OU=Nemendur,OU=Notendur,OU=Vi?f?ng,DC=net,DC=mydomain,DC=is
2012-03-02 17:23:16,325  WARN  [sync.ldap.LDAPUserRegistry] [main] Failed to resolve member of group 'Nemendur' with distinguished name: CN=2711912359,OU=Nemendur,OU=Notendur,OU=Vi?f?ng,DC=net,DC=mydomain,DC=is
[eeeendless entries like this snipped]

That OU that has the question marks is actually not correct.  It should be "Viðföng".   Apparently the non-ascii chars get replaced with question marks.   If this just in the log or could this be the root of my problem?

Does anyone know if Alfresco can handle non ascii characters properly in OU/CN/DN's in LDAP?

Thanks in advance.
Richard.

Outcomes