AnsweredAssumed Answered

Got System.ServiceModel.ProtocolException calling object ser

Question asked by rexmao on Mar 26, 2010
Hi,

I got a System.ServiceModel.ProtocolException when calling the method getObject in Object web service. My code was below:

objectS = ServiceFactory.getObjectService();
            objectS.getObject(repositoryId, "workspace://SpacesStore/f53faf88-d542-4d3a-b1de-366833b5f38d", "*", false, ObjectService.enumIncludeRelationships.none, "*", false, false, new wsstudy.ObjectService.cmisExtensionType());

Could someone give any help?

The stack trace was:

The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were:

——=_Part_0_14681722.1269564059413
Content-Type: application/xop+xml; charset=UTF-8; type="text/xml";
Content-Transfer-Encoding: binary
Content-ID: <root.message@cxf.apache.org>

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Header>
<wsse:Security xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"><wsu:Timestamp xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" wsu:Id="Timestamp-26812751"><wsu:Created xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">2010-03-26T00:40:59.413Z</wsu:Created><wsu:Expires xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">2010-03-26T00:45:59.413Z</wsu:Expires></wsu:Timestamp></wsse:Security></soap:Header><soap:Body><getObjectResponse xmlns="http://docs.oasis-open.org/ns/cmis/messaging/200908/" xmlns:ns2="http://docs.oasis-open.org/ns/cmis/core/200908/"><object><ns2:”。

Outcomes