AnsweredAssumed Answered

Alfresco & Geronimo

Question asked by mgiovagnoli on Mar 28, 2010
Latest reply on Oct 5, 2010 by alex4u2nv
I have problem installing Alfresco Community Edition 3.2r with Geronimo 2.2 using Tomcat 6.0 (Java Version 1.6.0_18)

Deploying alfresco.war running a command:

# java -jar /opt/geronimo-tomcat6-javaee5-2.2/bin/deployer.jar –user system –password manager deploy alfresco.war

got this error:

2010-03-29 21:05:28,555 ERROR [DeployTool] Error:
org.apache.geronimo.common.DeploymentException: Unable to deploy alfresco.war: Unable to resolve resource reference 'jdbc/dataSource' (Could not auto-map to resource.  Try adding a resource-ref mapping to your Geronimo deployment plan.
Search conducted in current module and dependencies:
[ALL: org.apache.geronimo.configs/tomcat6/2.2/car]
[ALL: org.apache.geronimo.configs/myfaces//car]
[ALL: org.apache.geronimo.configs/concurrent/2.2/car]
[ALL: org.apache.geronimo.configs/openjpa//car]
[ALL: org.apache.geronimo.configs/j2ee-corba-yoko//car]
[CLASSES: org.apache.geronimo.configs/openejb//car]
[ALL: org.apache.geronimo.configs/axis//car]
[ALL: org.apache.geronimo.configs/axis2//car]
)

        at org.apache.geronimo.deployment.cli.CommandDeploy.runCommand(CommandDeploy.java:45)
        at org.apache.geronimo.deployment.cli.CommandDistribute.executeOnline(CommandDistribute.java:149)
        at org.apache.geronimo.deployment.cli.CommandDistribute.execute(CommandDistribute.java:125)
        at org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java:168)
        at org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:45)
        at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
        at org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31)

I would like install Alfresco with Geronimo 2.2 because I need to deploy Liferay and Intalio on the same platform.

Regards

Outcomes