AnsweredAssumed Answered

node customized QName dont appear in it's xml representation

Question asked by mmrs on Mar 29, 2010
Hi,

i created a node with these properties :


    static final QName PROP_BUDGET_YEAR         = QName.createQName(NamespaceService.CONTENT_MODEL_1_0_URI, "budget_year");
    static final QName PROP_BUDGET_BRANCH      = QName.createQName(NamespaceService.CONTENT_MODEL_1_0_URI, "budget_branch");
    static final QName PROP_BUDGET_ACCNO      = QName.createQName(NamespaceService.CONTENT_MODEL_1_0_URI, "budget_accno");
    static final QName PROP_BUDGET_NO         = QName.createQName(NamespaceService.CONTENT_MODEL_1_0_URI, "budget_no");


now when i view the xml representaion of that node it gave me this :

  <cm:content xmlns="" xmlns:nt="http://www.jcp.org/jcr/nt/1.0" xmlns:app="http://www.alfresco.org/model/application/1.0" xmlns:d="http://www.alfresco.org/model/dictionary/1.0" xmlns:module="http://www.alfresco.org/system/modules/1.0" xmlns:sys="http://www.alfresco.org/model/system/1.0" xmlns:alf="http://www.alfresco.org" xmlns:ver="http://www.alfresco.org/model/versionstore/1.0" xmlns:mix="http://www.jcp.org/jcr/mix/1.0" xmlns:wca="http://www.alfresco.org/model/wcmappmodel/1.0" xmlns:bpm="http://www.alfresco.org/model/bpm/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0" xmlns:fm="http://www.alfresco.org/model/forum/1.0" xmlns:cm="http://www.alfresco.org/model/content/1.0" xmlns:reg="http://www.alfresco.org/system/registry/1.0" xmlns:rule="http://www.alfresco.org/model/rule/1.0" xmlns:wcmwf="http://www.alfresco.org/model/wcmworkflow/1.0" xmlns:wcm="http://www.alfresco.org/model/wcmmodel/1.0" xmlns:sv="http://www.jcp.org/jcr/sv/1.0" xmlns:view="http://www.alfresco.org/view/repository/1.0" xmlns:usr="http://www.alfresco.org/model/user/1.0" xmlns:act="http://www.alfresco.org/model/action/1.0" xmlns:wf="http://www.alfresco.org/model/workflow/1.0" xmlns:custom="custom.model" view:childName="cm:Account 1001.xml">
    <view:aspects>
      <sys:referenceable></sys:referenceable>
      <cm:auditable></cm:auditable>
      <cm:copiedfrom></cm:copiedfrom>
    </view:aspects>
    <view:acl>
      <view:ace view:access="ALLOWED">
        <view:authority>GROUP_EVERYONE</view:authority>
        <view:permission>All</view:permission>
      </view:ace>
    </view:acl>
    <view:properties>
      <cm:name>Account 1001.xml</cm:name>
      <sys:node-dbid>3966</sys:node-dbid>
      <sys:store-identifier>SpacesStore</sys:store-identifier>
      <cm:content>contentUrl=ll\content1.xml|mimetype=text/xml|size=202|encoding=UTF-8|locale=en_US_</cm:content>
      <cm:source>/app:company_home/cm:Accounting/cm:Clients/cm:Marwan_x0020_0001/cm:Budget_x0020_Maintenance/cm:Year_x0020_1990/cm:New_x0020_York_x0020_City_x0020_Branch/cm:Account_x0020_1001.xml</cm:source>
      <cm:modified>2010-03-28T18:54:17.718+03:00</cm:modified>
      <sys:node-uuid>2a42e2e4-3a82-11df-8ba8-e92027efb582</sys:node-uuid>
      <cm:created>2010-03-28T18:54:17.390+03:00</cm:created>
      <sys:store-protocol>workspace</sys:store-protocol>
      <cm:creator>CrcAdmin</cm:creator>
      <cm:modifier>CrcAdmin</cm:modifier>
    </view:properties>
    <view:associations></view:associations>
  </cm:content>


why my defined properties do not appear in the node xml ? and how can i make it appear ?

thnx in advance
Best Regards
mmrs

Outcomes