AnsweredAssumed Answered

Problems customizing model in unattended installation

Question asked by edovale on Apr 20, 2012
Latest reply on Apr 20, 2012 by nmcminn
Hello,
I am having problems customizing the content model using the bootstrap mode described in the official documentation here: http://docs.alfresco.com/4.0/index.jsp?topic=%2Fcom.alfresco.enterprise.doc%2Ftasks%2Fdeploy-bootstrap.html
We have spring context file that looks like this:

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>

    <!– Registration of new models –>   
  <bean id="custom.dictionaryBootstrap" parent="dictionaryModelBootstrap" depends-on="dictionaryBootstrap">
        <property name="models">
            <list>
                <value>alfresco/extension/customContentModel.xml</value>
            </list>
        </property>
    </bean>
         
</beans>

customContentModel.xml is located in the <alfresco_install>/tomcat/shared/classes/alfresco/extension as well as the spring context file above.
After doing this we start alfresco for the first time but the content model customizations are not taking place.

I am installing alfresco on ubuntu 11.04 64bits using the unattended mode and passing an options file. Alfresco is properly installed and the web ui is perfectly visible after the process. I can log in and browse around without problems.I am installing alfresco community 4.0.d.
The tomcat logs show no sign of errors.

What could be the problem?

Thanks in advance.

Erick.

Outcomes