AnsweredAssumed Answered

Subsystem External authentication 3.3

Question asked by loftux Moderator on Apr 26, 2010
Latest reply on May 11, 2012 by supalucas
I'm trying to set up external authentication susbsystem for Community 3.3.
For Alfresco explorer it works just fine, but not for Share.

alfresco-global.properties has
external.authentication.proxyUserName=
external.authentication.proxyHeader=X-Alfresco-Remote-User
external.authentication.enabled=true
external.authentication.userIdPattern=

For Share in webscript-framework-config-custom.xml
   <config evaluator="string-compare" condition="Remote">
        <remote>
            <endpoint>
                <id>alfresco</id>
                <name>Alfresco - user access</name>
                <description>Access to Alfresco Repository WebScripts that require user authentication</description>
                <connector-id>alfresco</connector-id>
                <endpoint-url>http://localhost:8080/alfresco/wcs</endpoint-url>
                <identity>user</identity>
                <external-auth>true</external-auth>
                <authenticator-id>alfresco-ticket</authenticator-id>
            </endpoint>
           
        </remote>
    </config>
Is there anything else that needs to be done for Share?

I've tried to set up some useful logging for Share, but nothing shows up. Running wireshark shows there is no communication from share to alfresco. Unless I manually enter credentials, then there is communication from share to Alfresco and I get logged in.

Outcomes