AnsweredAssumed Answered

Afresco 3.3 issues

Question asked by spl on Apr 29, 2010
Latest reply on Apr 29, 2010 by mikeh
Hi there.

I have deployed alfresco 3.3 after a week of testing main issues and customisation, as a replacement of a 3.0 final.
All is fine for the "essentials" but i have really annoying behavior for some users using content rules.

First of all, some config details :
Tomcat 6.0.18 shipped with alfresco 3.3 install
Running behind apache 2.2 httpd server using mod_jk (coyote:8099)

Some alf stuff at starting :
16:19:19,386  INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_20-b02; maximum heap size 2022,438MB
16:19:19,484  INFO  [service.descriptor.DescriptorService] Alfresco started (Community): Current version 3.3.0 (2765) schema 4009 - Originally installed version 3.3.0 (2765) schema 4009

Here is the facts :
Previously (3.0 final), inbound content rule assigning a simple workflow to a newly created document use to "persist" if content has been modified/updated via CIFS.
Now (3.3), this is not the case. Document is created, simple workflow is assigned OK. But if i update the content (word document), simple workflow assigned by inbound rule is lost.

I tried an "update" rule with no success :

It seems that the only way to tell alf the content has been updated (indeed, to apply the "update" rule) is to move the file on local disk, update it and then replace the file in the repository ???????

Updating content via the web interface make it as well, but i do need to trigger the rule on update file via CIFS !

How should i proceed to achieve this ?

Thanks.

Outcomes