AnsweredAssumed Answered

requested resource (/alfresco/s/api/login) is not available

Question asked by jmetzger on May 30, 2012
Latest reply on May 31, 2012 by jpotts
I think that I am close to sending a message to the Alfresco public CMIS server, but something isn't quite right.  My endpoint is:
http://cmis.alfresco.com/alfresco/s/api/login

My request message is:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns="http://www.alfresco.org/ws/service/authentication/1.0">
   <soapenv:Header>
   </soapenv:Header>
   <soapenv:Body>
      <ns:startSession>
         <ns:username>admin</ns:username>
         <ns:password>admin</ns:password>
      </ns:startSession>
   </soapenv:Body>
</soapenv:Envelope>

The response  is:
<html><head><title>Apache Tomcat/6.0.29 - Error report</title><style><!–H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}–></style> </head><body><h1>HTTP Status 404 - /alfresco/s/api/login</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>/alfresco/s/api/login</u></p><p><b>description</b> <u>The requested resource (/alfresco/s/api/login) is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.29</h3></body></html>

What am I doing wrong?

Thanks,
Jim Metzger

Outcomes