AnsweredAssumed Answered

CIFS & Kerberos Configuration

Question asked by lux209 on Jun 1, 2012
Latest reply on Jul 3, 2012 by lux209
Hi,

I'm have trouble to configure Kerberos for CIFS with my alfresco 4. The Active Directory authentication is working for all http connection, but I'm using ldap-ad instead of kerberos. CIFS is also working but only with Alfresco accounts not with AD.

I followed this guide to setup kerberos: http://docs.alfresco.com/4.0/index.jsp?topic=%2Fcom.alfresco.enterprise.doc%2Ftasks%2Fauth-kerberos-ADconfig.html

Kerberos seems ok for the system as I can use the "kinit <MyUserName>" command to create a ticket.

Then I modified the alfresco-global.properties to add the following:

### CIFS ###
cifs.enabled=true
cifs.domain=MYADDOMAIN.LOCAL
cifs.serverName=srvfcch-cms01
cifs.hostannounce=true


### Kerberos ###
kerberos.authentication.authenticateCIFS=true
kerberos.authentication.realm=MYADDOMAIN.LOCAL
kerberos.authentication.user.configEntryName=Alfresco
kerberos.authentication.cifs.configEntryName=AlfrescoCIFS
kerberos.authentication.http.configEntryName=AlfrescoHTTP
kerberos.authentication.cifs.password=Secret
kerberos.authentication.http.password=Secret
kerberos.authentication.defaultAdministratorUserNames=administrator

I did not changed the autehtication chain to add kerberos, but as I understood the chain is only for the web auth right ?

When I tried to reach the CIFS server from my WinXP I can see the following in the catalina.out:
 2012-06-01 09:24:19,705  ERROR [smb.protocol.auth] [AlfJLANWorker10] Kerberos logon error
2012-06-01 09:24:19,706  ERROR [smb.protocol.auth] [AlfJLANWorker10] java.lang.NullPointerException
2012-06-01 09:24:19,712  ERROR [smb.protocol.auth] [AlfJLANWorker11] Kerberos logon error
2012-06-01 09:24:19,727  ERROR [smb.protocol.auth] [AlfJLANWorker11] java.lang.NullPointerException
2012-06-01 09:24:29,486  ERROR [smb.protocol.auth] [AlfJLANWorker14] Kerberos logon error

I have to say that I'm a bit lost, and I don't where to start to debug the problem. Most of the doc I found on the net are for older version od Alfresco, and the config seems to be quite different..

Any help is warmly welcome !
Lucas

Outcomes