AnsweredAssumed Answered

Rebuild Index solr => error on tomcat log [ SOLVED ]

Question asked by gregd on Jun 4, 2012
Latest reply on Nov 18, 2013 by rjohnson
Hi,

I have installed Alfresco 4.0d on a CentOs 5.8 x86_64. I have configured LDAP-AD and gMail.

I tried to rebuild SOLR index because in the "/tomcat/logs/catalina.out", i had a message (sorry, I havn't save this log).

Since the rebuild, my first message log was disappeared, but i have a new message all the time in "/tomcat/logs/catalina.out" :

4 juin 2012 13:53:45 org.alfresco.solr.tracker.CoreTracker trackRepository
GRAVE: First transaction was not found with the correct timestamp.
4 juin 2012 13:53:45 org.alfresco.solr.tracker.CoreTracker trackRepository
GRAVE: SOLR has successfully connected to your repository  however the SOLR indexes and repository database do not match.
4 juin 2012 13:53:45 org.alfresco.solr.tracker.CoreTracker trackRepository
GRAVE: If this is a new or rebuilt database you SOLR indexes also need to be re-built to match the database.
4 juin 2012 13:53:45 org.alfresco.solr.tracker.CoreTracker trackRepository
GRAVE: You can also check your SOLR connection details in solrcore.properties.
4 juin 2012 13:53:45 org.alfresco.solr.tracker.CoreTracker trackRepository
GRAVE: Tracking failed
org.alfresco.error.AlfrescoRuntimeException: 05040077 Initial transaction not found with correct timestamp
        at org.alfresco.solr.tracker.CoreTracker.trackRepository(CoreTracker.java:1243)
        at org.alfresco.solr.tracker.CoreTracker.updateIndex(CoreTracker.java:491)
        at org.alfresco.solr.tracker.CoreTrackerJob.execute(CoreTrackerJob.java:45)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)

In the alfresco.log, they have no message.
My solrcore.properties is the default file :
data.dir.root=/data/alfresco-4.0.d/alf_data/solr
data.dir.store=workspace/SpacesStore
enable.alfresco.tracking=true
cache.alfresco.size=100
max.field.length=2147483647


#
# Properties loaded during alfresco tracking
#

alfresco.host=localhost
alfresco.port=8080
alfresco.port.ssl=8443
alfresco.cron=0/15 * * * * ? *
alfresco.stores=workspace://SpacesStore
alfresco.lag=1000
alfresco.hole.retention=3600000
alfresco.batch.count=1000

# encryption

# none, https
alfresco.secureComms=https

# ssl
alfresco.encryption.ssl.keystore.type=JCEKS
alfresco.encryption.ssl.keystore.provider=
alfresco.encryption.ssl.keystore.location=ssl.repo.client.keystore
alfresco.encryption.ssl.keystore.passwordFileLocation=ssl-keystore-passwords.properties
alfresco.encryption.ssl.truststore.type=JCEKS
alfresco.encryption.ssl.truststore.provider=
alfresco.encryption.ssl.truststore.location=ssl.repo.client.truststore
alfresco.encryption.ssl.truststore.passwordFileLocation=ssl-truststore-passwords.properties


Some documents are indexed, but not all. Havre you some idea ? 

Thanks

Greg

Outcomes