AnsweredAssumed Answered

3.3 transformer error when attempting to convert PDF to RTF

Question asked by danggang on May 20, 2010
Latest reply on May 20, 2010 by savic.prvoslav
Fresh install of 3.3 CE on Windows Server 2008 64-bit (could this be an issue?).

Following the "Smart Spaces" example here:

http://www.alfresco.com/products/ecm/tour/tour.html

I've created a content rule that is intended to convert any PDF document placed into one folder to an RTF document in another folder. Here's the rule:

Rule Type: inbound
Name: PDF to RTF
Description: PDF to RTF
Apply rule to sub spaces: No
Run rule in background: No
Disable rule: No
Conditions: Item has a mimetype of 'Adobe PDF Document'
Actions: Copies content to 'RTF' and transforms to 'Rich Text Format'

When I upload PDF file (have tried several different files), I get the following error message:

Please correct the errors below then click OK.

Failed to create content due to error: 04190003 Transformer for 'application/pdf' source mime type and 'application/rtf' target mime type was not found. Operation can't be performed

Do I need to enable something in the properties file for this to work? I created a rule that converts the from RTF to PDF and that works just fine. I'm assuming what I'm trying to do is possible since it was used as an example in the "tour," as I mentioned.

Any suggestions? Again, could running Alfresco on a 64-bit OS be causing problems? Also, I tried installing the latest nightly build (3.3G, May 18th) as well and this made no difference.

Outcomes