AnsweredAssumed Answered

Solr stopped working (after https certificate installation?)

Question asked by stasya on Jun 24, 2012
Latest reply on Aug 17, 2012 by marxiano533
Hi,

I am an Alfresco beginner, using community 4.d.

After configuring alfresco to use https and installing a new https certificate,
I've noticed that he recent documents dashlet stopped working (stuck on loading)
and the search stopped working as well.

I concluded that the SOLR was broken, and am trying to find the problem.

I am using the instructions in the following article for debugging the problem:
http://www.ixxus.com/blog/2012/06/getting-going-with-solr-alfresco-4/

I found out that while searching with alfresco default query handler works fine (result is empty as expected)
example (run from alfresco server):

https://localhost:8443/solr/alfresco/select/?q=alfresco&version=2.2&start=0&rows=10&indent=on


BUT Searching solr with the Alfresco related query handlers does not work in my system.
Example: When I run the following query:

https://localhost:8443/solr/alfresco/afts?q=@cm\:name:alfresco&indent=on

I get the following error:

description The server encountered an internal error (Namespace prefix cm is not mapped to a

namespace URI org.alfresco.service.namespace.NamespaceException: Namespace prefix cm is not

mapped to a namespace URI at org.alfresco.service.namespace.QName.createQName(QName.java:99)

at org.alfresco.service.namespace.QName.createQName(QName.java:121) at

org.alfresco.repo.search.impl.parsers.AlfrescoFunctionEvaluationContext.getLuceneFieldName

(AlfrescoFunctionEvaluationContext.java:384) at

org.alfresco.repo.search.impl.querymodel.impl.lucene.functions.LuceneFTSTerm.addComponent

(LuceneFTSTerm.java:70) at

org.alfresco.repo.search.impl.querymodel.impl.lucene.LuceneFunctionalConstraint.addComponent

(LuceneFunctionalConstraint.java:58) at

org.alfresco.repo.search.impl.querymodel.impl.lucene.LuceneQuery.buildQuery

(LuceneQuery.java:111) at org.alfresco.solr.AlfrescoSolrDataModel.getFTSQuery

(AlfrescoSolrDataModel.java:1012) at org.alfresco.solr.query.AlfrescoFTSQParserPlugin

$AlfrescoFTSQParser.parse(AlfrescoFTSQParserPlugin.java:80) at

org.apache.solr.search.QParser.getQuery(QParser.java:131) at

org.apache.solr.handler.component.QueryComponent.prepare(QueryComponent.java:89) at

org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:174) at

org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:131) at

org.apache.solr.core.SolrCore.execute(SolrCore.java:1316) at

org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:338) at

org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:241) at

org.apache.catalina.core.ApplicationFilterChain.internalDoFilter

(ApplicationFilterChain.java:235) at

org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at

org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at

org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at

org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:563) at

org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at

org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at

org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at

org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298) at

org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857) at

org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process

(Http11Protocol.java:588) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run

(JIoEndpoint.java:489) at java.lang.Thread.run(Thread.java:662) ) that prevented it from

fulfilling this request.


in my tomcat log, I see the following solr related exceptions:

https://rapidshare.com/files/362085766/stdout_20120624.log
'>
https://rapidshare.com/files/362085766/stdout_20120624.log


I've tried rebuilding solr indexes, but it didn't help.
I've gone over all of the configuration filesmentioned in the article, but they seem to be correct
and the handlers are defined.

Is it possible that my new https sertificate installation caused this problem?

Could anyone please point me in the right direction?

Here are some relevant configuration files:
https://rapidshare.com/files/3010895333/scripts.conf
https://rapidshare.com/files/3165752290/schema.xml
https://rapidshare.com/files/2891448187/solrcore.properties
https://rapidshare.com/files/117267727/solrconfig.xml
https://rapidshare.com/files/3557689299/alfresco-global.properties

Thank you,
Stasya

Outcomes