AnsweredAssumed Answered

Setup of ldap-ad in alfresco

Question asked by enr on Jun 1, 2010
Latest reply on Jun 7, 2010 by enr
Dear all,

I have many problems on setting up a working ldap-ad configuration in alfresco. I already tried several solutions proposed in other posts but they didn't work at all.
Here my  configuration:

repository.properties

authentication.chain=ldap-ad1:ldap-ad

ldap-ad-authentication.properties

ldap.authentication.active=true
ldap.authentication.allowGuestLogin=false
ldap.authentication.userNameFormat=%s@example.org
ldap.authentication.java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory
ldap.authentication.java.naming.provider.url=ldap://xxx.xxx.xxx.xxx
ldap.authentication.java.naming.security.authentication=simple
ldap.authentication.escapeCommasInBind=false
ldap.authentication.escapeCommasInUid=false
ldap.synchronization.active=true
ldap.synchronization.java.naming.security.principal=username@example.org
ldap.synchronization.java.naming.security.credentials=mypassword
ldap.synchronization.queryBatchSize=1000
ldap.synchronization.groupQuery=(objectclass\=group)




This is the error tomcat report on catalina.out:


13:58:32,848  INFO  [management.subsystems.ChildApplicationContextFactory] Startup of 'Authentication' subsystem, ID: [Authentication, managed, ldap-ad1] complete
13:58:32,902  INFO  [management.subsystems.ChildApplicationContextFactory] Startup of 'fileServers' subsystem, ID: [fileServers, default] complete
13:58:32,903  INFO  [management.subsystems.ChildApplicationContextFactory] Starting 'imap' subsystem, ID: [imap, default]
13:58:32,908  ERROR [org.alfresco.fileserver] [FTP] FTP Socket error : java.net.BindException: Permission denied
13:58:32,912  ERROR [org.alfresco.fileserver] java.net.BindException: Permission denied
13:58:32,912  ERROR [org.alfresco.fileserver]   at java.net.PlainSocketImpl.socketBind(Native Method)
13:58:32,912  ERROR [org.alfresco.fileserver]   at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)
13:58:32,912  ERROR [org.alfresco.fileserver]   at java.net.ServerSocket.bind(ServerSocket.java:319)
13:58:32,912  ERROR [org.alfresco.fileserver]   at java.net.ServerSocket.<init>(ServerSocket.java:185)



Please, could anyone tell me what it's wrong? It seems to be a credential problem but I tried to connect with an LDAP browser with the same credentials and it works.

Thank you very much.

Outcomes