AnsweredAssumed Answered

Content Auditing Issue

Question asked by garyj on Jul 23, 2012
Latest reply on Jul 30, 2012 by mrogers
Hi All,

I am running a clean install of Alfresco community, and am testing Content Auditing, as we are required to monitor and audit people's access to some of the documents on our system.

Basically I've gone through the wikis and the docs and have the following in my alfresco-global.properties


# Audit configuration
audit.enabled=true
audit.tagging.enabled=true
audit.alfresco-access.enabled=true
audit.alfresco-access.sub-events.enabled=true
audit.cmischangelog.enabled=true
audit.dod5015.enabled=false
# Setting this flag to true will force startup failure when invalid audit configurations are detected
audit.config.strict=true
# Audit map filter for AccessAuditor - restricts recorded events to user driven events
audit.filter.alfresco-access.default.enabled=true
audit.filter.alfresco-access.transaction.user=~System;~null;.*
audit.filter.alfresco-access.transaction.type=cm:folder;cm:content;st:site
audit.filter.alfresco-access.transaction.path=~/sys:archivedItem;~/ver:;.*
#Tried with and without the following line
audit.filter.alfresco-access.default.path=/app:company_home/.*

I have also set the logging to DEBUG for the audit modules and can see the output of the logging events in the alfresco.log file.

However when I go to Preview in Template -> show_audit.ftl there are no log entries shown for any of the content.

I've also noticed the following in alfresco.log when I try to access show_audit.ftl


21:16:00,488 DEBUG [org.alfresco.repo.audit.PropertyAuditFilter] Rejected
               /alfresco-access/transaction/type=ws:webassetCollection
   audit.filter.alfresco-access.transaction.type=cm:folder;cm:content;st:site
21:16:00,488 DEBUG [org.alfresco.repo.audit.PropertyAuditFilter] Rejected
               /alfresco-access/transaction/type=ws:webassetCollection
   audit.filter.alfresco-access.transaction.type=cm:folder;cm:content;st:site

Just wondering if anyone can point me in the right direction in relation to this issue, as the audit system is working but I just can't seem to get the audit events to display in Alfresco Explorer.

Thank you

garyj

Outcomes