AnsweredAssumed Answered

Loss of data!!! - Upgrade from 3.0 to 3.3g

Question asked by luca on Jun 30, 2010
I'm very disappointed. I'm using Alfresco 3.0 and I'm planning to move to the latest Alfresco version, but it's impossible due to a serious bug in Alfresco causing loss of data.

I found this issue in Jira(https://issues.alfresco.com/jira/browse/ALF-2719), but I don't think it's my case because the query described there doesn't return me any rows.

After the upgrade some nodes are missing their binary content and if I click over it I get 
The node's content is missing: 
   node: workspace://SpacesStore/3a2ee1d5-03b2-4cd3-842a-c1d6fc4d2d71
   reader: ContentAccessor[ contentUrl=store://2010/5/11/10/42/a9caf18f-b40a-4e3b-8655-f20615e25b3e.bin, mimetype=application/vnd.excel, size=0, encoding=UTF-8, locale=it_IT] 
Please contact your system administrator.

Before the upgrade that node was ok, and the property {http://www.alfresco.org/model/content/1.0}content was
{http://www.alfresco.org/model/content/1.0}content   contentUrl=store://2010/5/11/10/42/a9caf18f-b40a-4e3b-8655-f20615e25b3e.bin|mimetype=application/vnd.excel|size=76800|encoding=UTF-8|locale=it_IT_

Comparing the output of the Node Browser before and after the upgrade I didn't noticed any difference.

I think that some patch copies/modify/delete for some reason (What is this reason??) some binary documents in the contentstore, but it fail and doesn't restore the binary content…  :evil:

Can someone point me in the right direction?

1- What is this patch?
2- What does it do? And what could happen if I disable it?
3- What classes I have to inspect to understand why some binary are missing?

I hope some merciful Alfresco developer read it and try to help me!
Any help is highly appreciated!

Outcomes