AnsweredAssumed Answered

HTTP Status 404 for AuthenticationService

Question asked by ridgeway on Aug 27, 2012
Latest reply on Aug 29, 2012 by mitpatoliya
Hi All,
I've been using Alfresco Web Services to access an Alfresco repository (Alfresco 3.4.d) for the last few months with very encouraging success; however, for the last week, I've been struggling with an issue that I can't find a solution for. I'm trying to change a user's password.

When I tried to call the ChangePassword method, there was no error, but the password wasn't changed. I then read that before the web script can change the password the AdministrationService endpoint must be set. Here's the C# code that I tried:

            AdministrationService AdminService = new AdministrationService();
            this.setEndpointAddress("http://192.168.20.10:8080/alfresco/api/AuthenticationService");
            AuthenticationService authenticationService = new AuthenticationService();
            authenticationService.startSession("admin", "password");
            this.setEndpointAddress("http://192.168.20.10:8080/alfresco/api/AdministrationService");
            AdminService.changePassword(usernam, oldPasswd, newPasswd);
            authenticationService.endSession("admin");

This code causes an exception on the "StartSession" line with the following error:

The request failed with HTTP status 404: /alfresco/api/AuthenticationService.

I searched and cannot find an AuthenticationService file or directory on my server.

I have two questions:

1. Has anyone been able to successfully change a user's password using web scripts?
2. Does anyone know where the AuthenicationService and AdministrationService files are?

Thanks in advance for any help.

Regards

Outcomes