AnsweredAssumed Answered

FDK trouble

Question asked by swithun on Jul 5, 2010
Latest reply on Dec 8, 2011 by g_rathod
I've tried installing all three flavours of the Forms Development Kit (FDK) - AMP, jar and from source. The source build was installed with ant deploy-share-fdk-exploded.

After adding fdk:everything to /opt/alfresco/tomcat/shared/classes/alfresco/extension/web-client-config-custom.xml, I can specialise the type of content nodes in Alfresco, but not in Share.

I have the form console working partially in Share. It needs an item ID (workspace://SpacesStore/…), and will display a form of some kind for editing, viewing or creating. But the form is not the exciting and pretty form that is promised by the wiki. And changing the form ID has no effect - even to something nonsensical.

There are no errors in the log, and turning on debugging of forms doesn't give any useful information. I'm using a fresh install of the 3.3 community edition.

Has anyone else had this problem and solved it? I would like to get this working, so that I can figure out how to develop my own complex forms. Thanks.

Outcomes