AnsweredAssumed Answered

4.0.d on CentOS: WQS unable to connect to repository: Unauth

Question asked by butlerm1977 on Aug 29, 2012
I'm running Alfresco Community Edition 4.0.d on Centos 5.8 x64, firewall and SELinux are disabled.  After setting up I can log into http://ip/alfresco and http://ip/share no problems.  I created accounts, wiki documents, etc with no issues.  All was running good until yesterday no one could log in.  After examining, I found that the log files had filled up the 25GB partition.  After deleting all the logs, everything was back up and running.  Evidently the logs had been filling full of error and warnings. 

Every two seconds /webquickstart.log would append:

11:55:36,783 WARN  [org.alfresco.wcm.client.util.impl.GuestSessionFactoryImpl] WQS unable to connect to repository: Unauthorized

Also continuous "login failed" errors in the /alfresco.log.  I'm attaching both log files.  I did some forum searching and found this http://forums.alfresco.com/en/viewtopic.php?f=9&t=37157, I followed the advise and verified my login credentials in alfresco-global.properties.  Also I had changed the port from within this file to serve alfresco on port 80 rather than 8080.

As a followup, I have verified the correct postgesql login contained within alfresco.global-properties, but manually logging in with psql command line.

Alfresco.log - http://pastebin.com/rntySkLf
Webquickstart.log - http://pastebin.com/CvbDnFLE
alfresco.global-properties - http://pastebin.com/F3DrpPY7

Outcomes