AnsweredAssumed Answered

Alfresco Com 2.1 auf WAS 6.1: Probleme mit JSP-Tag

Question asked by pumpernickel on Nov 10, 2008
Latest reply on Nov 12, 2008 by pumpernickel
Hallo zusammen,

bei der Erstellung von WebForms in der Community 2.1-Version auf WebSphere 6.1.0.17 erhalte ich
auf der summary.jsp ( WEB-INF/jsp/wcm/create-form-wizard/summary.jsp ) folgenden Fehler:

com.ibm.ws.jsp.translator.JspTranslationException: JSPG0227E: Bei der Umsetzung von /jsp/wcm/create-form-wizard/summary.jsp:
/jsp/wcm/create-form-wizard/summary.jsp(46,1) –> JSPG0125E: Das benutzerdefinierte tag-Attribut description darf kein Laufzeitfragment sein.
wurde eine Ausnahme abgefangen.

In der JSP sieht das so aus:


<a:listItem label="<b>${WizardManager.bean.formTitle}</b>"
value="${WizardManager.bean.formName}"
image="/images/icons/webform_large.gif">
<jsp:attribute name="description">
<table width="100%" cellspacing="0" cellpadding="0" border="0">
<colgroup><col width="25%"/><col width="75%"/></colgroup>
<tbody>
<tr><td>${msg.description}:</td>
<td>
<c:choose>
<c:when test="${empty WizardManager.bean.formDescription}">
<span style="font-style:italic">${msg.description_not_set}</span>
</c:when>
<c:otherwise>${WizardManager.bean.formDescription}</c:otherwise>
</c:choose>
</td>
</tr>
<tr><td>${msg.schema_root_element_name}:</td><td>${WizardManager.bean.schemaRootElementName}</td></tr>
<tr><td>${msg.output_path_pattern}:</td><td>${WizardManager.bean.outputPathPatternForFormInstanceData}</td></tr>
</tbody>
</table>
</jsp:attribute>
</a:listItem>
Bei der Umsetzung des <jsp:attribute name="description">-Tags in a:listItem tritt der Fehler auf. Ich weiss, das dieses Attribut in der aktuellen Version
nicht mehr benutzt wird, jedoch treten dort andere Fehler auf, die ich ebenfalls nicht lösen konnte.
Für Tipps und Hinweise, auch solche, die eine gänzlich erfolgreiche Installation irgendeiner Alffresco Version auf WebSphere bestätigen, wäre ich sehr dankbar.

Grüße,

Thomas

Outcomes