AnsweredAssumed Answered

User Homes has been deleted

Question asked by chdrsto on Oct 4, 2012
Latest reply on Oct 4, 2012 by mrogers
Hi guys.

I have the problem that by installing Alfresco 3.x we have deleted the User Homes Folder. (right now I'm running 4.0.0 (7))
Since this (couple years ago) we have empty trash a couple of times. … This meens that the Home Users Folder is no more restorable through the "restore from trash" function.

To enable IMAP, I face the issue that the service starter is looking for User Homes Folder. I've already tried to create a "normal" folder called Homes Folder. Unfortunately it searchs the "app:home_users". By creating a normal one… it is called cm:home_users.

My question is:
How can I restore the Home Users Folder?
Ive already tried to run the script
userhome = companyhome.createNode("User Homes", "app:user_homes");
userhome.save();

But I face the message:
Please correct the errors below then click Finish.

    Failed to run Actions due to error: 09044361 Failed to execute script 'workspace://SpacesStore/37ce6010-9ce7-4f2d-a1f3-b99b87e48244': Class {http://www.alfresco.org/model/application/1.0}user_homes has not been defined in the data dictionary

Outcomes