AnsweredAssumed Answered

problems on advanced search

Question asked by georgess on Aug 11, 2010
Latest reply on Aug 25, 2010 by georgess
Hello

Excuse me for my English, I use a translator (Hum… I am French…), but this is not always very well translated.

I'm Alfresco Community 3.2.0 (r2384) and I have problems with the advanced search (screen localhost:8080\Alfresco\faces\jsp\browse\browse.jsp)
on the fields properties such as AUTHOR - TITLE - DESCRIPTION. I found the same problem on three fields.

sample content of the field DESCRIPTION:
test for advanced search

If I do a search with a single criterion of a word located anywhere in the field, Alfresco find documents that meet this criteria.
sample :  search
log trace : +@\{http\://www.alfresco.org/model/content/1.0\}description:'search"  AND (( TYPE:"{http://www.alfresco.org/model/content/1.0}content"   TYPE:"{http://www.alfresco.org/model/content/1.0}folder" ))
**************************************************

If I do a search with two criteria of two words in sequence and located anywhere in the field, Alfresco find documents
sample :  advanced search
Log trace : +@\{http\://www.alfresco.org/model/content/1.0\}description:'advanced search"  AND (( TYPE:"{http://www.alfresco.org/model/content/1.0}content"   TYPE:"{http://www.alfresco.org/model/content/1.0}folder" ))
**************************************************

If I do a search with two criteria of two words that do not follow each and located anywhere in the field, Alfresco can not find anything
sample  :  test search
Log trace : +@\{http\://www.alfresco.org/model/content/1.0\}description:'test search"  AND (( TYPE:"{http://www.alfresco.org/model/content/1.0}content"   TYPE:"{http://www.alfresco.org/model/content/1.0}folder" ))
**************************************************

The AND function seems not work on these fields. The goal is to find two or more words in whatever field
location like test search or search test

I tried to do as a full text search with +test +advanced or test AND advanced but this does not work.

Have you any idea? Incorrect customization Alfresco? bad syntax? Bug?
Thank you in advance for your help
Best regards

Outcomes