AnsweredAssumed Answered

Upgrading a REALLY old version of Alfresco

Question asked by major on Aug 13, 2010
Latest reply on Aug 13, 2010 by mrogers
Hello. I'm in a bind and am hoping to find a little help. As this is my first post EVAR I'll try not to ramble. I accepted this position because I'm a linux fanboy and it was an opportunity to work with linux in an enterprise environment. I'm tasked with upgrading a RHEL5 box running Alfresco 1.4 to the current version (3.3?) I've looked around and everything points to the Alfresco wiki :

http://wiki.alfresco.com/wiki/General_Upgrade_Process

We've got about 4 years of content ( > 200G) to be restored to the new box once online.

I looked at the wiki and if I'm correct, they recommend a simple install of 1.4 with running upgrades to bring the system current. Haven't been able to find all of the versions between 1.4 and current so I moved to another tack.

I considered a bare metal 3.3 build and subsequent restoration of the existing datastore but have had no luck in finding procedures to accomplish this.

I'm casting shouts to the wind for any assistance that can point me in the right direction.

My configuration:

RHEL5, MYSQL HDB database, Apache Tomcat 5, Alfresco 1.4 configured for LDAP authentication, OpenLDAP 2.4.23.

Thanks in advance

Major

Outcomes