AnsweredAssumed Answered

Alfresco SDK Project Import into Eclipse-Not Able to Run

Question asked by pramodkhare on Oct 24, 2012
Hi, I have this weird issue.
I have downloaded the Alfresco v4.2 Community SDK, and have properly imported "SDK AlfrescoEmbedded" and "SDK FirstFoundationClient" projects and have changed alfresco-global.properties properly, my postgres db is also up and running.

but when I try to run FirstFoundationClient.java is gives following message in eclipse console –>



Usage: javaw [-options] class [args…]
           (to execute a class)
   or  javaw [-options] -jar jarfile [args…]
           (to execute a jar file)

where options include:
    -client     to select the "client" VM
    -server     to select the "server" VM
    -hotspot     is a synonym for the "client" VM  [deprecated]
                  The default VM is client.
                 
    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A ; separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
    -D<name>=<value>
                  set a system property
    -verbose[:class|gc|jni]
                  enable verbose output
    -version      print product version and exit
    -version:<value>
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -jre-no-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
    -ea[:<packagename>…|:<classname>]
    -enableassertions[:<packagename>…|:<classname>]
                  enable assertions
    -da[:<packagename>…|:<classname>]
    -disableassertions[:<packagename>…|:<classname>]
                  disable assertions
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
    -agentlib:<libname>[=<options>]
                  load native agent library <libname>, e.g. -agentlib:hprof
                    see also, -agentlib:jdwp=help and -agentlib:hprof=help
    -agentpath:<pathname>[=<options>]
                  load native agent library by full pathname
    -javaagent:<jarpath>[=<options>]
                  load Java programming language agent, see java.lang.instrument
    -splash:<imagepath>
                  show splash screen with specified image


There is this scenario –>
I checked around this issue, if I remove project dependency of SDK AlfrescoEmbedded from SDK FirstFoundationClient project then if I create any dummy class with sysout in void main function, it works fine. But now FirstFoundationClient.java won't compile (obviously), if I add above dependency again my dummy also stops working and gives above error.

Somehow Eclipse is not able to run .class file on javaw.exe, its just running plain javaw.exe without any class file name.


I also have SDK for Alfresco 4.0, which is working fine and I am currently using it.
But when I try to import and use Alfresco 4.2 SDK, I am not able to execute/run any java class from SDK FirstFoundationClient project. And I remember while importing v4.0 SDK I have faced same issue and somehow I had solved it, i don't remember.

I know that this has nothing to do with Alfresco SDK files but with Eclipse Java Run Configuration.I have tried to change that Eclipse Run Config too, but no success.

If anyone has faced this issue, please help. Thanks in Advance.

Outcomes