AnsweredAssumed Answered

Tomcat - java - not enough space for code cache

Question asked by finalgrab on Oct 25, 2012
Dead alfresconists,
please help me solving a little problem. Weh a virtual server running on gentoo. Unfortunately it has the paxctl protection, so we install Alfresco on local gentoo server and then move it to the virtual one - it works and worked until now.
Something went wrong and I need new installation. I tried to install 4.2.a. On local it works. When I moved it to the virtual one, I can't start. I am stucked on error:
Error occurred during initialization of VM
Could not reserve enough space for code cache
I tried to find a solution, but I found nothing. Editing tomcat/script/ctl.sh and setting MaxPermSize, Xms and Xmx differently does not help.
Default was:
MaxPermSize:512m, Xms:128m, Xmx:1024m

Tried to change it to higher and lower but nothing happened. My fre* export in MB is:

             total       used       free     shared    buffers     cached
Mem:          5981       4081       1899          0        351       3138
-/+ buffers/cache:        591       5389
Swap:         4095          7       4088
Total:       10077       4089       5988

Do you have some tips?
Thanks

Outcomes