AnsweredAssumed Answered

shareUrl expression in wf-email template

Question asked by chrisokelly on Oct 30, 2012
Latest reply on Nov 20, 2013 by david.serres
Hi All,

I have run into a problem recently wherein the workflow emails sent to users have a malformed url at the bottom. At the bottom of the email (beneath "Click this link to edit the task:") the link is "https://our.server.address:8080/share/page/task-edit?taskId=activiti$26578" The problem is the combination of https:// and :8080. We have SSL set up on port 8443 here, so I want to change this so the link displays "https://...:8443/share/…" (preferably) or "http://...:8080/share/…".
Looking through wf-email.html.ftl I see this comes from the ${shareUrl} expression. I've tried using the javascript console to run a template just containing that expression, in case it was a root object, which it does not appear to be (it is undefined at least from the context of the javascript console).
I have looked through WorkflowNotificationUtils.java but this argument is notset in that class (although the other arguments are).
I've looked through the various OOTB workflow process definitions but don't see it being set (or indeed, anything to do with the notification emails).
In our alfresco-global.properties, we have -

alfresco.context=alfresco
alfresco.host=our.server.address
alfresco.port=8080
alfresco.port.ssl=8443
alfresco.protocol=https

share.context=share
share.host=our.server.address
share.port=8080
share.port.ssl=8443
share.protocol=https

Should I just change the share.port and alfresco.port to 8443? Would it cause any issues with accessing it via :8080?
I know my other option is to just hardcode the start of our URL in the template, however I'd prefer to follow the alfresco model as much as possible.

Outcomes