AnsweredAssumed Answered

Installing alfresco-community-spp-4.2.b.amp

Question asked by s7vensousa on Nov 7, 2012
Latest reply on Feb 20, 2013 by bone
I am trying to install alfresco-community-spp-4.2.b.amp and this error occurs:"10070000 An IO error was encountered during deployment of the AMP into the WAR"
Preview mode seems to be ok:
C:\Alfresco\bin>java -jar alfresco-mmt.jar install c:\Alfresco\amps\alfresco-com
munity-spp-4.2.b.amp c:\Alfresco\tomcat\webapps\alfresco.war -preview
Installing AMP 'c:\Alfresco\amps\alfresco-community-spp-4.2.b.amp' into WAR 'c:\
Alfresco\tomcat\webapps\alfresco.war'
Adding files relating to version '1.2' of module 'org.alfresco.module.vti'
   - File '/WEB-INF/lib/alfresco-vti-4.2.b.jar' added to war from amp
   - File '/WEB-INF/lib/jetty-6.1.26.jar' added to war from amp
   - File '/WEB-INF/lib/jetty-util-6.1.26.jar' added to war from amp
   - File '/WEB-INF/classes/alfresco/messages/vti-webview.properties' added to w
ar from amp
   - File '/WEB-INF/classes/alfresco/messages/vti-webview_ru.properties' added t
o war from amp
   - File '/WEB-INF/classes/alfresco/messages/webview_en.properties' added to wa
r from amp
   - File '/WEB-INF/classes/alfresco/messages/webview_ru.properties' added to wa
r from amp
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context/vti-
context.xml' added to war from amp
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context/vti-
handler-context.xml' added to war from amp
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context/vti.
properties' added to war from amp
   - Directory '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context
' added to war
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/module-conte
xt.xml' added to war from amp
   - Directory '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti' added
to war
   - File '/WEB-INF/classes/alfresco/templates/org/alfresco/vti/welcome-info.htm
l.ftl' added to war from amp
   - Directory '/WEB-INF/classes/alfresco/templates/org/alfresco/vti' added to w
ar
   - Directory '/WEB-INF/classes/alfresco/templates/org/alfresco' added to war
   - Directory '/WEB-INF/classes/alfresco/templates/org' added to war
   - File '/WEB-INF/classes/alfresco/templates/webscripts/org/alfresco/vti/vti-s
erver.get.desc.xml' added to war from amp

On real mode this happens:
C:\Alfresco\bin>java -jar alfresco-mmt.jar install c:\Alfresco\amps\alfresco-com
munity-spp-4.2.b.amp c:\Alfresco\tomcat\webapps\alfresco.war -verbose
Installing AMP 'c:\Alfresco\amps\alfresco-community-spp-4.2.b.amp' into WAR 'c:\
Alfresco\tomcat\webapps\alfresco.war'
Backing up WAR file…
WAR has been backed up to 'c:\Alfresco\tomcat\webapps\alfresco.war-1352304779992
.bak'
Adding files relating to version '1.2' of module 'org.alfresco.module.vti'
   - File '/WEB-INF/lib/alfresco-vti-4.2.b.jar' added to war from amp
   - File '/WEB-INF/lib/jetty-6.1.26.jar' added to war from amp
   - File '/WEB-INF/lib/jetty-util-6.1.26.jar' added to war from amp
   - File '/WEB-INF/classes/alfresco/messages/vti-webview.properties' added to w
ar from amp
   - File '/WEB-INF/classes/alfresco/messages/vti-webview_ru.properties' added t
o war from amp
   - File '/WEB-INF/classes/alfresco/messages/webview_en.properties' added to wa
r from amp
   - File '/WEB-INF/classes/alfresco/messages/webview_ru.properties' added to wa
r from amp
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context/vti-
context.xml' added to war from amp
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context/vti-
handler-context.xml' added to war from amp
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context/vti.
properties' added to war from amp
   - Directory '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/context
' added to war
   - File '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti/module-conte
xt.xml' added to war from amp
   - Directory '/WEB-INF/classes/alfresco/module/org.alfresco.module.vti' added
to war
   - File '/WEB-INF/classes/alfresco/templates/org/alfresco/vti/welcome-info.htm
l.ftl' added to war from amp
   - Directory '/WEB-INF/classes/alfresco/templates/org/alfresco/vti' added to w
ar
   - Directory '/WEB-INF/classes/alfresco/templates/org/alfresco' added to war
   - Directory '/WEB-INF/classes/alfresco/templates/org' added to war
   - File '/WEB-INF/classes/alfresco/templates/webscripts/org/alfresco/vti/vti-s
erver.get.desc.xml' added to war from amp
10070000 An IO error was encountered during deployment of the AMP into the WAR

Help :) anyone :)

Outcomes