AnsweredAssumed Answered

Alfresco 4.0.e Share access error

Question asked by ravil on Nov 12, 2012
when to trying to access share , get an error . /alfresco works fine, can see all sites .
The issue started when trying to roll back after failed 4.2.b upgrade , database/data folder has been restored back to old one .

A server error has occured.

There are a number of reasons why this could have happened:
You have attempted to access a page that does not exist - check the URL in the address bar.
You have attempted to access a page that is not accessable to you, such as a private Site dashboard.
A valid page has been requested but the server was unable to render it due to an internal error - contact your administrator.

Alfresco Log shows :

08:10:35,206 WARN  [org.springframework.extensions.surf.RequestContextUtil] Unable to locate theme model object with ID: default
08:10:35,206 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130007 Incorrectly configured endpoint ID: alfresco
08:49:23,723 WARN  [org.springframework.extensions.surf.RequestContextUtil] Unable to locate theme model object with ID: default
08:49:23,723 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130011 Incorrectly configured endpoint ID: alfresco
08:54:27,561 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130012 Incorrectly configured endpoint ID: alfresco
08:54:30,717 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130013 Incorrectly configured endpoint ID: alfresco
08:54:35,030 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130014 Incorrectly configured endpoint ID: alfresco
09:26:58,102 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130015 Incorrectly configured endpoint ID: alfresco
09:27:00,602 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130016 Incorrectly configured endpoint ID: alfresco
09:27:02,946 ERROR [org.alfresco.web.site] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130017 Incorrectly configured endpoint ID: alfresco

Catalina Log :

Nov 12, 2012 5:10:34 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.20.
Nov 12, 2012 5:10:35 PM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
Nov 12, 2012 5:10:38 PM org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Nov 12, 2012 5:10:39 PM org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
Nov 12, 2012 5:10:41 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8443
Nov 12, 2012 5:10:41 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 9317 ms
Nov 12, 2012 5:10:41 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Nov 12, 2012 5:10:41 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.29
Nov 12, 2012 5:10:41 PM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor alfresco.xml
Nov 12, 2012 5:11:02 PM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "org.apache.myfaces.webapp.StartupServletContextListener" is already configured for this context. The duplicate definition has been ignored.
Nov 12, 2012 5:14:06 PM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor host-manager.xml
Nov 12, 2012 5:14:06 PM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor manager.xml
Nov 12, 2012 5:14:06 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive share.war
Nov 12, 2012 5:14:36 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
Nov 12, 2012 5:14:36 PM org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Nov 12, 2012 5:14:36 PM org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
Nov 12, 2012 5:14:36 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8443
Nov 12, 2012 5:14:36 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 235343 ms

stdout.log

2012-11-12 17:11:49,023  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'sysAdmin' subsystem, ID: [sysAdmin, default]
2012-11-12 17:11:49,273  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'sysAdmin' subsystem, ID: [sysAdmin, default] complete
2012-11-12 17:12:12,269  WARN  [alfresco.util.AbstractTriggerBean] [Thread-2] Job ehCacheTracerJob is not active/enabled
2012-11-12 17:12:26,892  INFO  [extensions.webscripts.TemplateProcessorRegistry] [Thread-2] Registered template processor Repository Template Processor for extension ftl
2012-11-12 17:12:26,892  INFO  [extensions.webscripts.ScriptProcessorRegistry] [Thread-2] Registered script processor Repository Script Processor for extension js
2012-11-12 17:12:44,186  INFO  [domain.schema.SchemaBootstrap] [Thread-2] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
2012-11-12 17:12:54,231  INFO  [domain.schema.SchemaBootstrap] [Thread-2] No changes were made to the schema.
2012-11-12 17:12:55,918  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'Search' subsystem, ID: [Search, managed, lucene]
2012-11-12 17:12:58,699  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'Search' subsystem, ID: [Search, managed, lucene] complete
2012-11-12 17:13:07,665  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'thirdparty' subsystem, ID: [thirdparty, default]
2012-11-12 17:13:09,071  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'thirdparty' subsystem, ID: [thirdparty, default] complete
2012-11-12 17:13:09,071  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'OOoDirect' subsystem, ID: [OOoDirect, default]
2012-11-12 17:13:11,664  ERROR [util.exec.RuntimeExecBootstrapBean] [Thread-2] Bootstrap command failed:
Execution result:
   os:         Windows 2003
   command:    [/App/openoffice/program/soffice.exe, -accept=socket,host=127.0.0.1,port=8100;urp;StarOffice.ServiceManager, -env:UserInstallation=file:///K:/alf_data/oouser, -nologo, -headless, -nofirststartwizard, -nocrashrep, -norestore]
   succeeded:  false
   exit code:  2
   out:       
   err:        Cannot run program "/App/openoffice/program/soffice.exe": CreateProcess error=3, The system cannot find the path specified
2012-11-12 17:13:13,149  WARN  [alfresco.util.OpenOfficeConnectionTester] [Thread-2] An initial OpenOffice connection could not be established.
2012-11-12 17:13:13,149  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'OOoDirect' subsystem, ID: [OOoDirect, default] complete
2012-11-12 17:13:17,976  WARN  [node.index.FullIndexRecoveryComponent] [Thread-2] The indexes are not synchronized with the database.
2012-11-12 17:13:18,350  INFO  [repo.admin.ConfigurationChecker] [Thread-2] The Alfresco root data directory ('dir.root') is: k:alf_data
2012-11-12 17:13:18,585  INFO  [admin.patch.PatchExecuter] [Thread-2] Checking for patches to apply …
2012-11-12 17:13:19,491  INFO  [admin.patch.PatchExecuter] [Thread-2] No patches were required.
2012-11-12 17:13:19,522  INFO  [repo.module.ModuleServiceImpl] [Thread-2] Found 1 module(s).
2012-11-12 17:13:19,694  INFO  [repo.module.ModuleServiceImpl] [Thread-2] Starting module 'org.alfresco.module.vti' version 1.2.
2012-11-12 17:13:19,710  DEBUG [repo.module.ModuleComponentHelper] [Thread-2] Started module 'ModuleDetails[{module.version=1.2, module.description=Alfresco Vti Extension, module.id=org.alfresco.module.vti, module.repo.version.max=999, module.title=Vti, module.repo.version.min=0, module.installState=INSTALLED, module.installDate=2012-10-01T16:07:36.192+10:00}]' including 0components.
2012-11-12 17:13:19,710  DEBUG [repo.module.ModuleComponentHelper] [Thread-2] Installed module found in distribution: org.alfresco.module.vti
2012-11-12 17:13:19,788  WARN  [repo.module.ModuleServiceImpl] [Thread-2] A previously-installed module 'org_alfresco_module_dod5015' (version 1.0) is not present in your distribution.
2012-11-12 17:13:19,835  WARN  [repo.module.ModuleServiceImpl] [Thread-2] A previously-installed module 'org.alfresco.module.quickr' (version 1.0) is not present in your distribution.
2012-11-12 17:13:19,835  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'fileServers' subsystem, ID: [fileServers, default]
2012-11-12 17:13:21,428  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'Authentication' subsystem, ID: [Authentication, managed, passthru1]
2012-11-12 17:13:25,224  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'Authentication' subsystem, ID: [Authentication, managed, passthru1] complete
2012-11-12 17:13:26,177  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'fileServers' subsystem, ID: [fileServers, default] complete
2012-11-12 17:13:26,177  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'imap' subsystem, ID: [imap, default]
2012-11-12 17:13:26,661  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'imap' subsystem, ID: [imap, default] complete
2012-11-12 17:13:26,661  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'email' subsystem, ID: [email, outbound]
2012-11-12 17:13:26,786  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'email' subsystem, ID: [email, outbound] complete
2012-11-12 17:13:26,786  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'email' subsystem, ID: [email, inbound]
2012-11-12 17:13:27,036  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'email' subsystem, ID: [email, inbound] complete
2012-11-12 17:13:27,036  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'googledocs' subsystem, ID: [googledocs, default]
2012-11-12 17:13:28,098  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'googledocs' subsystem, ID: [googledocs, default] complete
2012-11-12 17:13:28,098  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'Subscriptions' subsystem, ID: [Subscriptions, default]
2012-11-12 17:13:28,145  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'Subscriptions' subsystem, ID: [Subscriptions, default] complete
2012-11-12 17:13:28,145  INFO  [repo.usage.UserUsageTrackingComponent] [Thread-2] Disabled - clear non-missing user usages …
2012-11-12 17:13:29,301  INFO  [repo.usage.UserUsageTrackingComponent] [Thread-2] Found 0 users to clear
2012-11-12 17:13:29,301  INFO  [repo.usage.UserUsageTrackingComponent] [Thread-2] … cleared non-missing usages for 0 users
2012-11-12 17:13:29,301  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'Synchronization' subsystem, ID: [Synchronization, default]
2012-11-12 17:13:29,489  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'Synchronization' subsystem, ID: [Synchronization, default] complete
2012-11-12 17:13:34,612  INFO  [service.descriptor.DescriptorService] [Thread-2] Alfresco JVM - v1.6.0_35-b10; maximum heap size 682.688MB
2012-11-12 17:13:34,644  INFO  [service.descriptor.DescriptorService] [Thread-2] Alfresco started (Community). Current version: 4.0.0 (7) schema 5,025. Originally installed version: 3.2.0 (r 2384) schema 3,003.
2012-11-12 17:13:34,644  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'ActivitiesFeed' subsystem, ID: [ActivitiesFeed, default]
2012-11-12 17:13:34,800  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'ActivitiesFeed' subsystem, ID: [ActivitiesFeed, default] complete
2012-11-12 17:13:34,800  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Starting 'Replication' subsystem, ID: [Replication, default]
2012-11-12 17:13:34,816  INFO  [management.subsystems.ChildApplicationContextFactory] [Thread-2] Startup of 'Replication' subsystem, ID: [Replication, default] complete
2012-11-12 17:13:38,284  INFO  [module.vti.VtiServer] [Thread-2] Vti server started successfully on port: 7070
2012-11-12 17:13:38,284  INFO  [module.vti.VtiServer] [Thread-2] Vti server SessionIdManagerWorkerName: jetty1
2012-11-12 17:13:54,171  WARN  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Unable to register script classpath:webscripts/org/springframework/extensions/cmis/content.get.desc.xml due to error: 10120001 Web Script document org/springframework/extensions/cmis/content.get.desc.xml is attempting to define the url '/cmis/content:GET' already defined by org/alfresco/cmis/client/content.get.desc.xml
2012-11-12 17:13:54,186  INFO  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Registered 464 Web Scripts (+1 failed), 731 URLs
2012-11-12 17:13:54,186  INFO  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Registered 2 Package Description Documents (+0 failed)
2012-11-12 17:13:54,186  INFO  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Registered 1 Schema Description Documents (+0 failed)
2012-11-12 17:13:54,186  INFO  [extensions.webscripts.AbstractRuntimeContainer] [Thread-2] Initialised Repository Web Script Container (in 15589.771ms)
2012-11-12 17:13:54,202  INFO  [extensions.webscripts.TemplateProcessorRegistry] [Thread-2] Registered template processor freemarker for extension ftl
2012-11-12 17:13:54,202  INFO  [extensions.webscripts.ScriptProcessorRegistry] [Thread-2] Registered script processor javascript for extension js
2012-11-12 17:14:23,024  INFO  [extensions.webscripts.TemplateProcessorRegistry] [Thread-2] Registered template processor freemarker for extension ftl
2012-11-12 17:14:23,195  INFO  [extensions.webscripts.ScriptProcessorRegistry] [Thread-2] Registered script processor javascript for extension js
2012-11-12 17:14:23,195  INFO  [extensions.webscripts.TemplateProcessorRegistry] [Thread-2] Registered template processor freemarker for extension ftl
2012-11-12 17:14:23,195  INFO  [extensions.webscripts.ScriptProcessorRegistry] [Thread-2] Registered script processor javascript for extension js
2012-11-12 17:14:33,615  INFO  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Registered 312 Web Scripts (+0 failed), 322 URLs
2012-11-12 17:14:33,615  INFO  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Registered 8 Package Description Documents (+0 failed)
2012-11-12 17:14:33,615  INFO  [extensions.webscripts.DeclarativeRegistry] [Thread-2] Registered 0 Schema Description Documents (+0 failed)
2012-11-12 17:14:33,880  INFO  [extensions.webscripts.AbstractRuntimeContainer] [Thread-2] Initialised Spring Surf Container Web Script Container (in 10676.936ms)
2012-11-12 17:14:33,896  INFO  [extensions.webscripts.TemplateProcessorRegistry] [Thread-2] Registered template processor freemarker for extension ftl
2012-11-12 17:14:33,896  INFO  [extensions.webscripts.ScriptProcessorRegistry] [Thread-2] Registered script processor javascript for extension js
2012-11-12 17:14:36,177  INFO  [site.servlet.SSOAuthenticationFilter] [Thread-2] SSOAuthenticationFilter initialised.
2012-11-12 17:15:10,214  WARN  [extensions.surf.RequestContextUtil] [http-8080-1] Unable to locate theme model object with ID: default
2012-11-12 17:15:11,215  ERROR [alfresco.web.site] [http-8080-1] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10120003 Incorrectly configured endpoint ID: alfresco
2012-11-13 08:10:35,206  WARN  [extensions.surf.RequestContextUtil] [http-8080-3] Unable to locate theme model object with ID: default
log4j:ERROR Failed to rename [alfresco.log] to [alfresco.log.2012-11-12].
2012-11-13 08:10:35,206  ERROR [alfresco.web.site] [http-8080-3] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130007 Incorrectly configured endpoint ID: alfresco
2012-11-13 08:49:23,723  WARN  [extensions.surf.RequestContextUtil] [http-8080-4] Unable to locate theme model object with ID: default
2012-11-13 08:49:23,723  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130011 Incorrectly configured endpoint ID: alfresco
2012-11-13 08:54:27,561  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130012 Incorrectly configured endpoint ID: alfresco
2012-11-13 08:54:30,717  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130013 Incorrectly configured endpoint ID: alfresco
2012-11-13 08:54:35,030  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130014 Incorrectly configured endpoint ID: alfresco
2012-11-13 09:26:58,102  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130015 Incorrectly configured endpoint ID: alfresco
2012-11-13 09:27:00,602  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130016 Incorrectly configured endpoint ID: alfresco
2012-11-13 09:27:02,946  ERROR [alfresco.web.site] [http-8080-4] org.springframework.extensions.surf.exception.PlatformRuntimeException: 10130017 Incorrectly configured endpoint ID: alfresco

Outcomes