AnsweredAssumed Answered

vtiUrl and https?

Question asked by bopolissimus on Nov 13, 2012
Hello,

I have VTI/sharepoint configured to be reachable from windows clients only via https and via port 7070.

However, when I browse to:

https://sharepoint.mydomain.com:7070/alfresco/

the page says:

"To make use of the Alfresco SharePoint Module with Microsoft office, you should supply the URL http://sharepoint.mydomain.com:7070/alfresco/"

In alfresco-global.properties I have:

# Sharepoint #
vti.server.port=7071
vti.server.external.host=https://sharepoint.mydomain.com

#apache listens on 7070 and forwards to our local (unencrpted) 7071.
vti.server.external.port=7070
vti.ipv6.enabled=false

given that configuration, I'd expect that message to say "…supply the URL https://sharepoint.mydomain.com:7070/alfresco/"

Is there a bug in setting up ${vtiUrl} (referred to in: web-server/alfresco/WEB-INF/classes/alfresco/templates/org/alfresco/vti/welcome-info.html.ftl) or is there some other vti.* properties I need to configure?

Background:

  I have apache listening on https://sharepoint.mydomain.com:7070
  I have alfresco listening (http) on localhost:7071

  apache forwards the https to alfresco (http).

That's all working except for that help message.

Gerald

Outcomes