AnsweredAssumed Answered

Alfresco Enterprise 3.3 doesn't login on WebSphere6.1

Question asked by mario.dandrea on Sep 7, 2010
Latest reply on Sep 8, 2010 by mario.dandrea
I have just installed Alfresco 3.3 Enteprise Edition on a IBM WebSphere Application Server 6.1 and on a IBM WebSphere Application Server 7.0
I followed all instructions I could found on the web, including "" and  "Installing_and_Configuring_Alfresco_for_Enterprise_Trial_3_3_SP1.pdf"

I solved all conflicts on the WAS 7.0 installation, but still I can't make it works properly on WAS 6.1
The application starts but when I try to login I get the following error:
org.springframework.extensions.webscripts.WebScriptException - 08070001 Script url /facebook/jsp/login.jsp does not map to a Web Script.
and I get the same error if I try to access every URL starting as http://localhost:9080/alfresco/facebook/ but I can access all others Alfresco Web Scripts.
I don't need the Facebook Servlet but I'm afraid it could be mandatory for the login in Alfresco

I checked the mapping configuration in the file web.xml and I found that /Facebook is well configured


and the FacebookServlet is inside alfresco-remote-api-3.3.jar, in the same directory of the others libs (alfresco_war.ear\alfresco.war\WEB-INF\lib)

That's the whole stack:

Error:   Not Found (404) - Requested resource is not available.

Message:   08070001 Script url /facebook/jsp/login.jsp does not map to a Web Script.

Exception:   org.springframework.extensions.webscripts.WebScriptException - 08070001 Script url /facebook/jsp/login.jsp does not map to a Web Script.
Server:   Alfresco Enterprise v3.3.0 (g 2860) schema 4.100

Unfortunately, I MUST make it works on WAS6.1 because my company (and the clients of my company) use WAS6.1 for all their Java Application.
Is there any way to make it works, even disabiling the Facebook Servlet at login?
Thans for the help,