AnsweredAssumed Answered

3.2->3.3 08180000 A previous schema upgrade failed

Question asked by vwillems on Sep 18, 2010
Hello,

I have 3.2 running on Tomcat6. When I try to upgrade tot 3.3 via the war, I get this error message after +/-2 minutes:

20:27:18,569  INFO  [extensions.webscripts.ScriptProcessorRegistry] Registered script processor Repository Script Processor for extension js
20:27:23,640  INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
20:29:23,919  ERROR [domain.schema.SchemaBootstrap] Schema auto-update failed
org.alfresco.error.AlfrescoRuntimeException: 08180000 A previous schema upgrade failed or was not completed.  Revert to the original database before attempting the upgrade again.
        at org.alfresco.repo.domain.schema.SchemaBootstrap.onBootstrap(SchemaBootstrap.java:1292)
        at org.springframework.extensions.surf.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:56)
        at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:97)
        at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:294)
        at org.springframework.context.support.AbstractApplicationContext.finishRefresh(AbstractApplicationContext.java:858)
        at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:419)

Any ideas?

Thanks,

Vincent

Outcomes