AnsweredAssumed Answered

Error de Openoffice

Question asked by xagaes on Dec 9, 2008
Latest reply on Dec 9, 2008 by pjcaracuel_2349
Hola a todos.

Os comento un error que me surge al usar alfresco junto con openoffice. Lo primero que hago es cargar el openoffice con este comando:

/opt/openoffice.org3/program/soffice "-accept=socket,host=localhost,port=8100; urp;StarOffice.ServiceManager" -nologo -headless -nofirststartwizard &

Carga sin ningun problema. Pero a la hora de arrancar alfresco, sale el siguient error:

17:53:33,967 ERROR [web.context.ContextLoader] Context initialization failed
net.sf.jooreports.openoffice.connection.OpenOfficeException: connection failed: socket,host=localhost,port=8100,tcpNoDelay=1; com.sun.star.lang.DisposedException: com.sun.star.io.IOException: java.net.SocketException: Socket closed
        at net.sf.jooreports.openoffice.connection.AbstractOpenOfficeConnection.connect(AbstractOpenOfficeConnection.java:77)
        at org.alfresco.util.OpenOfficeConnectionTester.testAndConnect(OpenOfficeConnectionTester.java:147)
        at org.alfresco.util.OpenOfficeConnectionTester.checkConnection(OpenOfficeConnectionTester.java:116)
        at org.alfresco.util.OpenOfficeConnectionTester.onBootstrap(OpenOfficeConnectionTester.java:90)
        at org.alfresco.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:62)
        at org.springframework.context.event.SimpleApplicationEventMulticaster$1.run(SimpleApplicationEventMulticaster.java:77)
        at org.springframework.core.task.SyncTaskExecutor.execute(SyncTaskExecutor.java:49)
        at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:75)
        at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:241)
        at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:349)
        at org.springframework.web.context.support.AbstractRefreshableWebApplicationContext.refresh(AbstractRefreshableWebApplicationContext.java:156)
        at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:246)
        at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:184)
        at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:49)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:448)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
17:53:33,968 ERROR [[Catalina].[localhost].[/alfresco]] Excepción enviando evento inicializado de contexto a instancia de escuchador de clase org.springframeork.web.context.ContextLoaderListener
net.sf.jooreports.openoffice.connection.OpenOfficeException: connection failed: socket,host=localhost,port=8100,tcpNoDelay=1; com.sun.star.lang.DisposedException: com.sun.star.io.IOException: java.net.SocketException: Socket closed

Y ahi se queda. No termina de arrancar. En cambio si no cargo el openoffice, arranca perfecto y a la primera.

¿Os suena que puede ser?

Un saludo y gracias por vuestro tiempo

Outcomes