AnsweredAssumed Answered

Issue while integrating OpenOffice - Reg

Question asked by ganmaku on Oct 14, 2010
Latest reply on Oct 14, 2010 by ssaravanan
Hello Team,

My environment is as follows:

Alfresco Enterprise edition 3.3.1
Windows XP
JDK 1.6
Tomcat 6.0

I changed repository.properties file as follows:
# External executable locations
ooo.exe=oo.root=C:\\Program Files\\OpenOffice.org 3\\program\\soffice

I got the below error when I am trying to start the Alfresco server after successfully installing openoffice setup to machine.

2010-10-14 16:42:16,500  INFO  [management.subsystems.ChildApplicationContextFac
tory] Startup of 'thirdparty' subsystem, ID: [thirdparty, default] complete
2010-10-14 16:42:16,500  INFO  [management.subsystems.ChildApplicationContextFac
tory] Starting 'OOoDirect' subsystem, ID: [OOoDirect, default]
2010-10-14 16:42:16,531  INFO  [alfresco.config.JndiPropertyPlaceholderConfigure
r] Loading properties file from class path resource [alfresco/alfresco-shared.pr
operties]
2010-10-14 16:42:16,734  ERROR [util.exec.RuntimeExecBootstrapBean] Bootstrap co
mmand failed:
Execution result:
   os:         Windows XP
   command:    [oo.root=C:\Program Files\OpenOffice.org 3\program\soffice, -acce
pt=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager, -env:UserInsta
llation=file:///D:/alfresco-enterprise-tomcat-3.3.1-fds/${ooo.user}, -nologo, -h
eadless, -nofirststartwizard, -nocrashrep, -norestore]
   succeeded:  false
   exit code:  2
   out:
   err:        Cannot run program "oo.root=C:\Program Files\OpenOffice.org 3\pro
gram\soffice": CreateProcess error=2, The system cannot find the file specified
2010-10-14 16:42:17,781  WARN  [alfresco.util.OpenOfficeConnectionTester] An ini
tial OpenOffice connection could not be established.
2010-10-14 16:42:17,796  INFO  [management.subsystems.ChildApplicationContextFac
tory] Startup of 'OOoDirect' subsystem, ID: [OOoDirect, default] complete
2010-10-14 16:42:17,796  INFO  [management.subsystems.ChildApplicationContextFac
tory] Starting 'OOoJodconverter' subsystem, ID: [OOoJodconverter, default]
2010-10-14 16:42:17,796  INFO  [alfresco.config.JndiPropertyPlaceholderConfigure
r] Loading properties file from class path resource [alfresco/alfresco-shared.pr
operties]
2010-10-14 16:42:17,828  INFO  [management.subsystems.ChildApplicationContextFac
tory] Startup of 'OOoJodconverter' subsystem, ID: [OOoJodconverter, default] com
plete
2010-10-14 16:42:19,312  INFO  [repo.admin.ConfigurationChecker] The Alfresco ro
ot data directory ('dir.root') is: D:\alfresco-enterprise-tomcat-3.3.1-fds\alf_d
ata
2010-10-14 16:42:19,453  INFO  [admin.patch.PatchExecuter] Checking for patches
to apply …
But soffice.exe file exists in the "C:\Program Files\OpenOffice.org 3\program" folder.

Any help would be highly beneficial for me.

Outcomes